0

A client of mine has a product named "C137-936 and T324-456" When Searching for "C137-936 T324-456" this product show up in the results, but when explicitly searching for "C137-936 and T324-456" the product isn't present.

Why is Magento missing this, and how can this issue be fixed?

2
  • Try to change system configuration for search. System->configuration->Catalog->Catalog Search->Search Type Oct 30, 2017 at 7:15
  • Thanks, Tried it already. Didn't help.
    – Roy Toledo
    Nov 1, 2017 at 14:00

1 Answer 1

0

In the configuration of the article you must config the visibility for the article to: catalog, search or: search

In the search configruation you can change the configuration for the max. searchquery and the max. number of worts.

5
  • Thanks for the reply, but I fail to see how this answers the question. The products does appear on search results.
    – Roy Toledo
    Oct 31, 2017 at 10:18
  • I thought that the "C137-936 and T324-456" does not appear becouse the searchquery is to long.
    – Marcel
    Oct 31, 2017 at 21:10
  • No, query dues goes through, but product isn't in results.
    – Roy Toledo
    Nov 1, 2017 at 14:00
  • I tried it with your articel name with the "and" between. I got the same result. In advanced search it works but not in standard search. In the standard search I got a result with all articles with and in the name.
    – Marcel
    Nov 2, 2017 at 8:03
  • So I think it is the searchlogic. If I change the search config to fulltext I got the search result that you want (C137-936 and T324-456).
    – Marcel
    Nov 2, 2017 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.