-1
Magento 1.9.1
Magento 1.9.3
future install of Magento 2.2.0
VPS server account with MultiPHP Manager

I have a VPS server. The hosting company installed a "MultiPHP Manager" in the WHM. Currently, these pHp versions are available to be selected:

PHP 5.4
PHP 5.5
PHP 5.6

There is one store (domain) which runs on Magento 1.9.1 which has PHP 5.5 selected in the MultiPHP Manager. Now we're launching a new project (store/domain) and we selected Magento 2.2.0 for that. When I tried to install Magento 2.2.0 via the Softaculous program in that account's/domain's cPanel, it gave the following Error:

The following errors were found :

You can try installing the previous version of Magento by selecting from the "Choose Version" dropdown below 
Required PHP version greater than equal to 7.0.2 AND found version is : 5.6.31

I checked the minimum system requirements and it seems these are the valid versions for Magento 2.2.0:

enter image description here

(as per here - http://devdocs.magento.com/guides/v2.2/install-gde/system-requirements-tech.html )

Here are the 3 important questions:

  1. Is it possible to run Magento 1.9.1/1.9.3 on PHP 7.x?
    1. If not - Can the PHP 5.5 and PHP 7.x coexist on the VPS server account?
    2. If neither 1. or 2. is possible - is there any other solution on how to make this work? (run Magento 1.9.1 and Magento 2.2.0 on the same VPS server account)?

UPDATE: I made a ticket with my hosting company and even-though they kept telling me always (when I asked about this before) that it is not possible to run different PHP versions on the same VPS server - now it turns out that it is possible! As stated by the technician:

There was no need to remove any older version in order to proceed with enabling the listed ones. We know that some scripts on some sites require older versions of PHP. Since there was no need to remove any of the older versions, the following are enabled: PHP versions 7.0, 7.1, 7.2. They are available now as well.

I tried to run the install of Magento 2.2.0 again and now I get the following Error:

The following errors were found :

Required PHP extension not found : bcmath Required PHP extension not found : curl Required PHP extension not found : iconv Required PHP extension not found : mcrypt Required PHP extension not found : intl Required PHP extension not found : mbstring Required PHP extension not found : pdo_mysql Required PHP extension not found : soap Required PHP extension not found : zip Required PHP extension not found : gd

0

You need to get your hosting company to install these extensions on your server - http://devdocs.magento.com/guides/v2.2/install-gde/system-requirements-tech.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.