1

I have run into a problem where the Customer "Sign In" button stopped working after a few uses. Everything else so far about the store seems to be working as expected.

I am using a clean install of Magento 2.2.0 Open Source version, that was installed using Softaculous at my web hosting service.

Steps taken to produce the error:

In the store, I add a virtual, downloadable item to the cart.

I click the cart icon in the top right of the screen.

I click on the "View and Edit Cart" link in the small window that opens.

I click the "Proceed to Checkout" button on the right side of the screen.

The account popup form appears, and I put my credentials into it.

I click the "Sign In" button, and it turns a darker color of gray.

Nothing happens afer that, but the "Create Account" button on that same popup works though.

I tried using Internet Explorer and Opera browsers with a clean browser cache, but the result is still the same.

I posted the bug on the Magento 2 github page, but they haven't replied with a fix, and neither is there a fix listed as of today on their release page at https://magento.com/tech-resources/download

The reply that I did get on their github page is "The issue is already fixed in develop branch, 2.2.0", but since I am still a newbie when it comes to using Magento 2, I don't know what a develop branch is or how or where I am supposed to fix the problem.

Below is the Opera browser console output. These errors are only shown after the Sign In button is clicked:

JQMIGRATE: Logging is active

/pub/static/version1507935652/frontend/Magento/luma/en_US/Magento_Customer/js/view/authentication-popup.js:76

Uncaught TypeError: Cannot read property 'currentTarget' of undefined

at UiClass.login (/pub/static/version1507935652/frontend/Magento/luma/en_US/Magento_Customer/js /view/authentication-popup.js:76)

at HTMLFormElement. (/pub/static/version1507935652/frontend/Magento/luma/en_US/knockoutjs/knockout .js:4241)

at HTMLFormElement.dispatch (/pub/static/version1507935652/frontend/Magento/luma/en_US/jquery.js:5226)

at HTMLFormElement.elemData.handle (/pub/static/version1507935652/frontend/Magento/luma/en_US/jquery.js:4878)

Attached below is the image of what I am talking about.

Any help is appreciated. Thank you very much.

sign_in_popup

1

As per your shared detail. I compare old (2.0) and new version(2.3-develop) of magento, I found some code changes in html template and js file

In Version :- 2.3-develop

1 authentication-popup.js#L76

login: function (formUiElement, event) {
        var loginData = {},
            formElement = $(event.currentTarget) 
...

2 authentication-popup.html#L53

<form class="form form-login"
              method="post"
              data-bind="event: {submit: login }"
...

In Version :- 2.0

3 authentication-popup.js#L67

login: function(loginForm) {
            var loginData = {},
                formDataArray = $(loginForm).serializeArray();
...

4 authentication-popup.html#L53

<form class="form form-login"
              method="post"
              data-bind="submit:login"
...

'currentTarget' of undefined - It means event variable is not define in html template file. which you seen in magento 2.3-develop is fixed see pt.2.

You used magento 2.2.0 in that JS got updated (pt.1) but html template not update (pt.4).

If still having same concern please update html template & JS file (pt.1 & pt.2).

  • 1
    Kanhaiya lal, I gave you an up-tick for this answer, but I "solved" this issue a while back, by upgrading to a newer version of Magento. This answer may well help me with the same issue in version 2.3.1, now that I am no longer a newbie with Magento 2. Thank you very much. – Krang Apr 25 at 15:33
  • @Krang you got and solve your concern that great, onething is that you upgraded to newer version that solved your problem. but suppose same concern will happen with someone else and they will not have idea (for newbie's), they might not be try this given answer. Best or My suggestion is that if you feel this given solution helped and solved your problem then please mark as valid as so others can use same when they will get same kind of concern (on same version only). hope you got my point. – Kanhaiya lal Apr 26 at 6:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.