6

I am getting this error in admin custom module of Magento 2.

Something went wrong with processing the default view and we have restored the filter to its original state. admin grid error.

  • did you ever figure this out? :) – treyBake Nov 13 '17 at 16:34
  • Please post code here from xml file of UI component – Keith Dec 4 '17 at 8:40
  • 1
    I am also getting this error. Have you found any solution for this? – Magecode Feb 22 '18 at 9:23
  • Please update the answer once you find the solution. I'm also getting the same error on 2.3 – Mansoorkhan Cherupuzha Apr 3 at 15:23
6

You have to delete an order grid entry from the ui_bookmark table. In a ui_bookmark table, delete the row where you want to reset the filter.

or if you don't know which entry of order then you can truncate this table.

  • followed ur answer but no luck could you please advise is there any alternative way to fix this issue? – Nagaraju K Aug 20 at 13:02
1

After I created some custom modules, I found this error appear when my database table has column named "order" and I want to show the "order" in the admin grid listing.

Use table column named "order" in Magento2 will issue some unpredictable errors in some other situation too, like collection filter. This is a bug I saw someone post it to official Magento github, but it seems not be fixed in Magento2.2.2 :(

To fix the problem, you have to rename the table column "order" to other name, like "sequence".

Hope my answer will help you :)

0

I also had issue just now with Magento CMS Page Grid, and it was because the JSON response from /mui/index/render/ Ajax request was invalid.

Fixing the JSON response fixed the issue for me.

Hope this helps.

0

This is not an answer but I think this can help. I also faced this type of issue in my custom module(in all environments local, staging and production) which was working perfectly fine few days ago. I tried all possible solutions but it is still showing error

ERR_BLOCKED_BY_CLIENT in console for mui/index/renderer

and

Something went wrong with processing the default view and we have restored the filter to its original state. in grid

Later I found this issue is occurs only in Chrome Browser.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.