8

I am getting this error in admin custom module of Magento 2.

Something went wrong with processing the default view and we have restored the filter to its original state. admin grid error.

6
  • did you ever figure this out? :)
    – treyBake
    Nov 13, 2017 at 16:34
  • Please post code here from xml file of UI component
    – Keith
    Dec 4, 2017 at 8:40
  • 1
    I am also getting this error. Have you found any solution for this?
    – Magecode
    Feb 22, 2018 at 9:23
  • Please update the answer once you find the solution. I'm also getting the same error on 2.3 Apr 3, 2019 at 15:23
  • facing same issue with Magento2.3.2 Feb 5, 2020 at 12:50

6 Answers 6

7

You have to delete an order grid entry from the ui_bookmark table. In a ui_bookmark table, delete the row where you want to reset the filter.

or if you don't know which entry of order then you can truncate this table.

6
  • followed ur answer but no luck could you please advise is there any alternative way to fix this issue? Aug 20, 2019 at 13:02
  • after truncate facing same issue with Magento2.3.2 Feb 5, 2020 at 12:51
  • me also facing same issue after truncating this table Apr 9, 2020 at 6:29
  • This SQL command fixed it for me UPDATE catalog_product_entity SET sku='' WHERE sku IS NULL;
    – Hector
    Apr 9, 2020 at 17:04
  • After deleting the grid column data , refresh cache and check. Apr 9, 2020 at 17:18
1

I also had issue just now with Magento CMS Page Grid, and it was because the JSON response from /mui/index/render/ Ajax request was invalid.

Fixing the JSON response fixed the issue for me.

Hope this helps.

2
  • 1
    Can you tell us how you did this? Jul 11, 2019 at 10:22
  • Sander van Zuidam, I did this for a custom ui grid error using the browser console: I opened the console and scrolled down to the GET ... mui/index/render... part and opened the response which, in my case, led to an error of the form {"error":"CustomModel with id "34769" does not exist.", "errorcode":"0"} and worked from there.
    – Isolde
    Sep 9, 2020 at 17:34
1

After I created some custom modules, I found this error appear when my database table has column named "order" and I want to show the "order" in the admin grid listing.

Use table column named "order" in Magento2 will issue some unpredictable errors in some other situation too, like collection filter. This is a bug I saw someone post it to official Magento github, but it seems not be fixed in Magento2.2.2 :(

To fix the problem, you have to rename the table column "order" to other name, like "sequence".

Hope my answer will help you :)

1

It turns out i had products with no SKU, so this fixed it for me instead of having to truncate ui_bookmark table each time:

UPDATE catalog_product_entity SET sku='' WHERE sku IS NULL;

0

This is not an answer but I think this can help. I also faced this type of issue in my custom module(in all environments local, staging and production) which was working perfectly fine few days ago. I tried all possible solutions but it is still showing error

ERR_BLOCKED_BY_CLIENT in console for mui/index/renderer

and

Something went wrong with processing the default view and we have restored the filter to its original state. in grid

Later I found this issue is occurs only in Chrome Browser.

0

This error could be related to session size. If you see this in your system.log

report.WARNING: Session size of 271683 exceeded allowed session max size of 256000.

then you should increase the admin max session size like this:

bin/magento config:set -c system/security/max_session_size_admin 512000

This solved for me in Magento 2.4.3-p1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.