I am trying magento's New Magento Security Tool with below url


But i can not Verify Site Ownership, every time when i click on Verify Confirmation Code it's give me same error

Unable to verify this site. Please recheck your verification code and try again!

enter image description here

I have followed all step that provide in right block

  • Do you use a domain name or IP address? did you found the given code in the site's html?
    – M.Elwan
    Commented Oct 25, 2017 at 7:07
  • 1
    yes i am using domain name with https and i can see code in source Commented Oct 25, 2017 at 10:12
  • we have seen this when server/proxy/cache removed comments from source code. Can you email me with site URL so we can check peter @ magento.com Commented Oct 25, 2017 at 19:07
  • Hello peter, It's seems working now.Yesterday it was not working but now it's working fine thank you Commented Oct 26, 2017 at 5:02

6 Answers 6


I faced the same issue. This issue seems to be from portal itself.

You can verify the code is added in your site from your browser by looking the source code of your website. search the code if you find the code simply submit the form in the portal. This will add your site and then you can run your scan by selecting the run scan from action column.


We are seeing often this problem coming from web server/proxy/cache removing comments from the output before sending to the browser. If comment with verification ID is removed, the verification will not be successful. The current suggestion is to work with your hosting provider to disable comment removal but Magento will try to enable alternative site verification, eg through meta tags.


When using a custom theme (never happens with a clean magento2 installation, at least for me), if you put the verification code following the tutorial, which will tell you to place the verification code in the "head", it will not work for whatever reason. This is confirmed by inspecting the code after you follow the tutorial, as the verification code will not show up. However, placing the html comment on the footer solved the problem for me in multiple websites with different templates.

In some cases the web server itself is filtering comments out which will make for an invalid verification as well as Piotr Kaminski also mentioned.

Hope this helps!


I have successfully completed the ownership of the site. I have copied and pasted the conformation code as it is in "HTML Head(Miscellaneous Scripts)" and click on save config. then i have click on "Verify Confirmation code" its working

Regards, Shiva


I just ran into this issue. I fixed it by

1: adding the script tag to my default_head_blocks.xml file 2: purging the varnish cache

That made submit work


Replace your .htaccess with the default one.

Then add the code to the site, this time the scanner should accept your site to test.

Get the scan report and then place original .htacess file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.