4

I'm very new to Magento so maybe there's something I'm missing, but I'm totally lost as to what to try next.

I have a favicon that I would like to put on my brand new Magento 1.9.3.6 install. The file is 32x32 pixels and named "favicon.gif". Using the admin panel, I uploaded the file to

System > Config > General > Design > HTML Head > Favicon Icon

After saving the file, it shows its location as "default/favicon.gif". (The design package is set to "RWD" by default. I'm not sure if that's affecting it...?)

After uploading, clearing both Magento's cache and my browser's cache, I see the same, default Magento icon. Viewing the source code shows me the favicon location as

<link rel="icon" href="<WEBSITE_NAME>/media/favicon/default/favicon.gif" type="image/x-icon" />

Upon navigation to this folder, I see the favicon I uploaded (?!). So the browser finds the right image, but still puts the Magento icon up?

I'm so confused. Any help is greatly appreciated.

  • 1
    You must clear cache, System -> Cache Management, you have 2 buttons in the upright corner. – St3phan Oct 24 '17 at 15:34
  • I guess I should have been more explicit, but I did flush both Magento Cache and Cache Storage. Just tried it again, just in case, and flushed browser cache in Chrome using F12 > Application > Clear Storage > (everything checked) Clear site data. Still getting the same Magento favicon. – k.x Oct 24 '17 at 15:51
  • You may be seeing the default magento favicon but the rest of the world is seeing no icon whatsoever. You need to clear your browser's cache to see the changes to the favicons. – Yiorgos Moschovitis Oct 24 '17 at 15:57
  • Okay, I'm seeing that as well. (I think I hadn't flushed caches when I tested on another browser earlier. I guess "Clear site data" in Chrome isn't enough to get rid of the favicon.) Now that that's straightened up, any idea why it's not pushing the correct icon through? – k.x Oct 24 '17 at 16:06
  • Try to change the permissions for it. – St3phan Oct 24 '17 at 18:51
2

After much fiddling, I have finally got it to work. Posting an answer here for anyone with this problem in the future.

If you're having this problem, follow these steps:

  1. Go to your Magento Admin Page, to the favicon settings, located here:

    System > Config > General > Design > HTML Head > Favicon Icon

  2. Delete your current favicon by checking the box and clicking Save Config.

  3. Visit your homepage, preferably from a browser without any of your site's cache. I used Google Chrome's Guest feature.

  4. On your site, press Ctrl + U (or F12, you just want to view the site's code).

  5. Find the line in the header that points to the favicon (should now be Magento's default favicon). For me, it was located in

    /skin/frontend/base/default

  6. Replace the favicon.ico with another image. (I used another .ico, not sure if other formats will be friendly here.)

  7. Clear your browser's cache and refresh.

0

You may have the file uploaded properly, but not all browsers support certain file types as Favicons.

read here - Uploading a Favicon - Magento Docs

I would suggest making a copy of your favicon.gif and renaming it to favicon.ico and upload that image, flush your cache, and see if it shows.

Alternatively you can use a webservice like this to generate a new .ico for you.

  • I'll try this, but I doubt this is the issue, since I still see Magento's favicon in my personalized Chrome browser, but if I view it from my phone or from a guest Chrome browser, it shows up as no favicon. – k.x Oct 24 '17 at 18:38
  • Well, looks like Magento doesn't even want to take my .ico file. I just get "invalid image" even though it's 16x16 file named "favicon.ico"...? Wish that error message wasn't so vague. – k.x Oct 24 '17 at 18:50
  • We use PNG files with our store and have not had any issues. You can also try leaving this area blank and putting the favicon.ico in the /root directory of your store's installation. – Steven J Oct 24 '17 at 19:10
  • 1
    Ha! You did it! After deleting that image, it reverted back to the default Magento logo, (from no favicon) so I hunted that down and replaced it. Thanks a ton! – k.x Oct 24 '17 at 19:35
  • 1
    I actually wrote up my own answer, detailing the steps I took to resolve it. I need to wait another day before I can mark it as correct though, but I have a set a reminder to do so. :p – k.x Oct 25 '17 at 12:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.