1

I have duplicated the theme in app folder and modified the theme.xml accordingly. But it displays like below screen shot.

http://brick.learnup.ro/lux/

enter image description here

It should be look like this -

http://brick.learnup.ro/

enter image description here

I have to mention that I have successfully ran all the commands in SSH:

setup:upgrade setup:di:compile cache:flush setup:static-content:deploy

and set the permissions right.

The problem occurs only with the duplicates of this theme

Thank you

2

Copy the app & pub folder of your theme & paste it into your Magento root directory & from there fire the below command

To set & install the new modules of your theme.

php bin/magento setup:upgrade

To set & make visible the static content of your theme that is css,js,Images.

php bin/magento setup:static-content:deploy

For your convenience & making sure about it that every thing is ready run this command also to remove the cache

php bin/magento cache:flush

Basically the last command is used for the cache clearing.

2
  • Ok, so I have tried using the initial setup for the theme. But the problem is elsewhere: the store is either not configured right, or there is another problem which I can't figure out. In console I get >>Uncaught SyntaxError: Invalid or unexpected token ( index ): 423<< Oct 19 '17 at 20:38
  • You could run this command for such an error php bin/magento indexer:reindex & if the problem is still persists than you can ask it in proper manner as an question on the same platform Thank You! Oct 20 '17 at 18:17
0

So the problem was I had forgotten to create the widgets for this new theme - with the "Design Package/Theme" set to it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.