2

Recently I have upgrade my Magento store from 1.3 to 1.8. I fixed almost errors. Now am facing a strange issue in the last step of the check out. When I click the place order button I get an undefined alert and nothing happens after that.

Somebody told me to alert transport.responseText on skin/design/frontend/package/theme/js/opcheckout.js to show the errors.

But I can't get any error in this alert. It just contains an html code of the check out page.

Anybody know what is the issue here.

1
  • I was having same issue and i fixed it by removing my checkout module .
    – Nafees
    Jan 14, 2015 at 14:15

2 Answers 2

3

app/design/frontend/default/YOUR_THEME/template/checkout/onepage/review/info.phtml

Find code

echo $this->getUrl('checkout/onepage/saveOrder');

Replace it with:

echo $this->getUrl('checkout/onepage/saveOrder', array('form_key' => Mage::getSingleton('core/session')->getFormKey()));

Make sure to take file backup

3
  • i cant find $this->getUrl('checkout/onepage/saveOrder'); on my info.phtml , my old magento version is 1.3 and upgraded to 1.8
    – vks
    May 13, 2014 at 13:19
  • Try disabling modules related to checkout May 13, 2014 at 14:01
  • <script type="text/javascript"> //<![CDATA[ review = new Review('<?php echo $this->getUrl('checkout/onepage/saveOrder', array('form_key' => Mage::getSingleton('core/session')->getFormKey())) ?>', '<?php echo $this->getUrl('checkout/onepage/success') ?>', $('checkout-agreements')); //]]> </script> This code is in the end May 13, 2014 at 14:03
3

I had a same problem. Then i changed

echo $this->getUrl('checkout/onepage/saveOrder');

to

echo $this->getUrl('checkout/onepage/saveOrder', array('form_key' => Mage::getSingleton('core/session')->getFormKey()));

But the template file's path is

app/design/frontend/default/YOUR_THEME/template/checkout/onepage/review.phtml

It worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.