6

I'm trying to update magento2 from 2.1.9 to 2.2.0. But, I have got issue. What I did.

composer require magento/product-community-edition 2.2.0 --no-update

./composer.json has been updated

composer update

Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - magento/data-migration-tool 2.1.4 requires magento/framework ~100.1 -> satisfiable by magento/framework[100.1.9, 100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.2.0-rc20].
    - magento/data-migration-tool 2.1.4 requires magento/framework ~100.1 -> satisfiable by magento/framework[100.1.9, 100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.2.0-rc20].
    - magento/data-migration-tool 2.1.4 requires magento/framework ~100.1 -> satisfiable by magento/framework[100.1.9, 100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.2.0-rc20].
    - Can only install one of: magento/framework[101.0.0, 100.1.9].
    - Can only install one of: magento/framework[101.0.0, 100.1.0-rc1].
    - Can only install one of: magento/framework[101.0.0, 100.1.0-rc2].
    - Can only install one of: magento/framework[101.0.0, 100.1.0-rc3].
    - Can only install one of: magento/framework[101.0.0, 100.1.0].
    - Can only install one of: magento/framework[101.0.0, 100.1.1].
    - Can only install one of: magento/framework[101.0.0, 100.1.2].
    - Can only install one of: magento/framework[101.0.0, 100.1.3].
    - Can only install one of: magento/framework[101.0.0, 100.1.4].
    - Can only install one of: magento/framework[101.0.0, 100.1.5].
    - Can only install one of: magento/framework[101.0.0, 100.1.6].
    - Can only install one of: magento/framework[101.0.0, 100.1.7].
    - Can only install one of: magento/framework[101.0.0, 100.1.8].
    - Can only install one of: magento/framework[101.0.0, 100.2.0-rc20].
    - Can only install one of: magento/framework[101.0.0, 100.1.9].
    - magento/product-community-edition 2.2.0 requires magento/framework 101.0.0 -> satisfiable by magento/framework[101.0.0].
    - Installation request for magento/product-community-edition 2.2.0 -> satisfiable by magento/product-community-edition[2.2.0].
    - Installation request for magento/data-migration-tool 2.1.4 -> satisfiable by magento/data-migration-tool[2.1.4].

My composer.json is

{
    "name": "magento/project-community-edition",
    "description": "eCommerce Platform for Growth (Community Edition)",
    "type": "project",
    "version": "2.1.0",
    "license": [
        "OSL-3.0",
        "AFL-3.0"
    ],
    "require": {
        "magento/product-community-edition": "2.2.0",
        "composer/composer": "@alpha",
        "magento/data-migration-tool": "2.1.4",
        "fooman/googleanalyticsplus-m2": "^2.0",
        "tinify/magento2": "^1.1"
    },
    "require-dev": {
        "phpunit/phpunit": "4.1.0",
        "squizlabs/php_codesniffer": "1.5.3",
        "phpmd/phpmd": "@stable",
        "pdepend/pdepend": "2.2.2",
        "fabpot/php-cs-fixer": "~1.2",
        "lusitanian/oauth": "~0.3 <=0.7.0",
        "sebastian/phpcpd": "2.0.0"
    },
    "config": {
        "use-include-path": true
    },
    "autoload": {
        "psr-4": {
            "Magento\\Framework\\": "lib/internal/Magento/Framework/",
            "Magento\\Setup\\": "setup/src/Magento/Setup/",
            "Magento\\": "app/code/Magento/"
        },
        "psr-0": {
            "": "app/code/"
        },
        "files": [
            "app/etc/NonComposerComponentRegistration.php"
        ]
    },
    "autoload-dev": {
        "psr-4": {
            "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
            "Magento\\Tools\\": "dev/tools/Magento/Tools/",
            "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
            "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
            "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
        }
    },
    "minimum-stability": "alpha",
    "prefer-stable": true,
    "repositories": {
        "0": {
            "type": "composer",
            "url": "https://repo.magento.com/"
        },
        "data-migration-tool": {
            "type": "git",
            "url": "https://github.com/magento/data-migration-tool"
        },
        "foomanartifacts": {
            "type": "artifact",
            "url": "vendor/fooman/packages"
        }
    },
    "extra": {
        "magento-force": "override"
    }
}

Maybe someone can help me with this issue. Thanks.

10

magento/data-migration-tool 2.1.4 is only compatible with Magento 2.1. In order to upgrade to Magento 2.2, you need to update this to 2.2.0 as well.

The error message is saying you're trying to update magento/framework to 101.0.0 (for 2.2), but magento/data-migration-tool 2.1.4 is only compatible with magento/framework 100.1. It can't resolve that dependency conflict, so it fails out.

Try:

composer require magento/product-community-edition 2.2.0 --no-update
composer require magento/data-migration-tool 2.2.0 --no-update

Then

composer update
  • Glad to hear! If an answer solves your problem, please mark it as the accepted solution: magento.stackexchange.com/help/accepted-answer Thanks. – Ryan Hoerr Oct 12 '17 at 16:35
  • What if the module is not compatible with that version? I am getting below error [InvalidArgumentException] Could not find package [modulename] in a version matching 2.2.0 – Ashish Viradiya Dec 5 '18 at 4:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.