2

I'm using Magento 1.9.3.4 AND KeyCDN. I configured the js/media/css files to come from CDN. On the CDN I enabled the CORS. The CDN uses HTTP/2, shared SSL and the Origin Shield setting is set to "disabled".

The problem is with my Magento WYSIWYG editor, because the javascript files come from CDN and I receive the error:

SecurityError: Permission denied to access property "tinymce" on cross-origin object

I tried to deactivate HTTPS for the backend but it's still enabled.

Please tell me if I can make some changes in order to make the tinyMce to work from CDN. Otherwise I'll have to change the JS path to use the server path instead of the CDN.

I changed System/Configuration/Web/Secure and Unsecure Javascript Base URL to: https://examplecdn.com/js/ instead of: {{unsecure_base_url}}js/

If you have any idea please say it. Thanks.

3

I found the answer here: https://magento.stackexchange.com/a/61593/761

The Unsecure URL settings configured in the default config (top left) in the admin section. Are global – they affect all the stores and the admin area. In order to disable the CDN on the admin, but keep it for the website, change the scope of your configuration to Main Website (top left), uncheck the ‘Use Default’ settings, and then add in the CDN urls.

So under Current Configuration Scope: Default config you should use ;

http://www.yourdomain.com/

Under Current Configuration Scope: Main Website and default store view you should use

http://cdn.yourdomain.com/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.