3

I'm not sure why but all of a sudden when I try to import my .csv file to update my products it gets stuck on the "Please Wait" screen. It was working just fine one day then the next it's doing this. What do I do... Please help!

  • Might be a server issue, check the logs under var/logs – gabehou Oct 9 '17 at 14:57
  • Has your csv increased in size? Have you tried importing just a single product? – jscar Oct 9 '17 at 15:48
0

Try submitting the file again with the network window opened (F12 on Chrome) & search for the request to see if there are any visible errors.
I had a similar issue & in my case I had to increase the value of client_max_body_size on nginx.conf.
It may also be a result of too low memory_limit/max_execution_time/post_max_size/... on php.ini

| improve this answer | |
0

The actual "Import" button (after the validation step), trigger an AJAX request to the server. If the server takes too long to respond (1 minute by default, depending our your server/php.ini settings), the "Please wait" notification will never disappear.

This doesn't mean however, that your import isn't running. The AJAX request still triggered the import to run. Check the import_history table in your database and search for your import there. If the execution_time field is set, it means that the import is processed and you can view the output in the summary field.

| improve this answer | |
0

I would wait and check htop and inspect the tree of the top process. If your using a limited environment, it may be running slow because of not enough resources.

As soon as I started an import of an ~11M file in Magento 2.3 , my site became unresponsive, /usr/sbin/apache2 -k start began consuming >90% of my CPU while mysql started consuming more memory. There are multiple of /usr/sbin/apache2 -k start running all the time but during import one went to ~100%.

Eventually (after 5min) the "Please wait" notification did go away and the page updated on it's own. Then CPU and memory consumption went back to normal. If the import has errors, they will be listed on the page after "Please wait..." goes away.

| improve this answer | |
0

Faced the same issue make sure that indexers mode is set to "UPDATE BY SCHEDULE" if it isn't already this worked for me.

| improve this answer | |
0

Another possibility is that X-Frame-Options: "Deny" may be set by default for paths within your admin in your server configuration.

I received the following error in my browser console when clicking the “Check Data” button.

Though the import didn't have any errors after checking, the subsequent AJAX response that would allow me to import the data (or view any errors) was not being loaded to the browser and therefore I could not proceed.

X-Frame Options Error Adding the following configuration under a location block pertaining to my admin resolved the issue and allowed the "Import" button to appear after checking:

add_header X-Frame-Options "SAMEORIGIN";

| improve this answer | |
0

I ran into the same issue when I was trying to import some advanced prices.

I had to re-enable the Temando_Shipping module.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.