0

From today marketplace start rejects my modules by issues in composer, it's look like:

Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1

  • The requested package sy/callback 0.1.2 exists as sy/callback[0.1.0, 0.1.1] but these are rejected by your constraint.

Installation failed, reverting ./composer.json to its original content.

[Pipeline] }

[Pipeline] // stage

[Pipeline] sh

[DockerOperationsPHP71Magento22CE] Running shell script

  • echo Failure

Failure

What is need to do? anybody)

My composer.json is:

{
    "name": "sy/callback",
    "description": "Extension",
    "license": [
        "OSL-3.0"
    ],
    "type": "magento2-module",
    "version": "0.1.2",
    "authors": [
        {
            "name": "Slava Yurthev",
            "email": "[email protected]",
            "homepage": "https://github.com/SlavaYurthev/",
            "role": "Developer"
        }
    ],
    "autoload": {
        "files": [ "registration.php" ],
        "psr-4": {
            "SY\\Callback\\": ""
        }
    }
}

UPDATE:

Magento Support Answer:

Hi Slava,

We have identified a bug within our install automated testing and pushed a fix to production this morning. We are going to rerun the tests today for affected extensions (I added your extension to this list). You will see a separate email from us that will say either that you passed or failed (for a valid reason). No action is required on your part. Just be on the lookout for the email.

0

2 Answers 2

1

When I visit your module I can't see any tags : https://github.com/SlavaYurthev/Callback-M2/tags

Have you tried actually tagging your latest commit with 0.1.2 ?

1
  • no) but anyway error from start post is fixed, start post updated. Commented Oct 11, 2017 at 19:57
0

Your composer json file should be like this, EDIT

{
"name": "fooman/emailattachments-m2",
"license": "OSL-3.0",
"description": "Automatically attach pdf and terms and conditions documents to outgoing sales emails.",
"type": "magento2-module",
"version": "2.1.0",
"autoload": {
    "psr-4": {
        "Fooman\\EmailAttachments\\": ""
    },
    "files": [
        "registration.php"
    ]
},
"require": {
    "php": "~5.6.0|7.0.2|7.0.4|~7.0.6|~7.1.0",
    "magento/framework": "^100.0 | ^101.0.0",
    "magento/module-backend": "^100.0.2",
    "magento/module-sales": "^100.0.2 | ^101.0.0",
    "magento/module-checkout-agreements": "^100.0.2"
},
"require-dev": {
    "phpunit/phpunit": "^6.2"
},
"minimum-stability": "dev",
"prefer-stable": true,
"suggest": {
    "fooman/printorderpdf-m2": "Allows attaching the order confirmation pdf to the order confirmation email",
    "fooman/pdfcustomiser-m2": "Allows to easily customise the sales pdfs while also reducing file sizes "
}

}

If your module is for Magento 2.2 then change PHP version to,

    `"php": "7.0.2|7.0.4|~7.0.6|~7.1.0"`

This is sample JSON format which is approved by magento marketplace, You can find this extension from this link

Note : I am not prorating this extension, this is free extension on marketplace

7
  • nope, this is not fix issue, i change version to 1.0.0 and "require" and still see these errors on technical review Commented Oct 5, 2017 at 20:07
  • also i tried copy your code and pass tech review and nothing... Commented Oct 5, 2017 at 20:19
  • Nothing means ?
    – Keyur Shah
    Commented Oct 5, 2017 at 20:20
  • i was mean - nothing changed, still see these errors Commented Oct 5, 2017 at 20:27
  • this extension Updated: 16 September, 2017, these errors start showing from today , 1 day ago all been fine Commented Oct 6, 2017 at 6:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.