1

I try to upgrade Magento 2.1.6 to Magento 2.1.9.

To do this I ran this command:

composer require magento/product-community-edition 2.1.9 --no-update

after this I ran : composer update and I received this error:

Your requirements could not be resolved to an installable set of packages.

Problem 1

  • The requested package magento/product-community-edition 2.1.9 exists as magento/product-community-edition[2.1.6] but these are rejected by your constraint

My composer.json look like this:

{
    "name": "magento/project-community-edition",
    "description": "eCommerce Platform for Growth (Community Edition)",
    "type": "project",
    "version": "2.1.9",
    "license": [
        "OSL-3.0",
        "AFL-3.0"
    ],
    "require": {
        "magento/product-community-edition": "2.1.9",
        "composer/composer": "@alpha",
        "ebizmarts/mailchimp-lib": "^3.0",
        "mailchimp/mc-magento2": "^1.0",
        "dividebv/phpdivideiq": "^0.5.0",
        "beberlei/assert": "^2.4"
    },
.........................................

Even I remove the rest of the extensions like this, is still not working

   "require": {
            "magento/product-community-edition": "2.1.6",
            "composer/composer": "@alpha"

        },

How I can avoid this issue?

3 Answers 3

0

In your composer.json edit your version number on line 5 and 11 to 2.1.9, Then just run composer update

4
  • after i run composer require magento/product-community-edition 2.1.9 --no-update my composer.json is 2.1.9, but i have the same issue Oct 4, 2017 at 8:23
  • have you setup a repository in your composer.json to get the new version from?
    – Koen
    Oct 4, 2017 at 8:30
  • no. but i am not sure what do you mean Oct 4, 2017 at 8:57
  • you should surely just update the packages you're interested in rather than every package installed on your system? eg composer update foo/bar baz/qux Oct 4, 2017 at 9:00
0

Remove the rest of the extensions like

"magento/product-community-edition": "2.1.6",

is not enough, you should remove it from composer lock as well, or do like below,

composer remove magento/product-community-edition --no-update
composer require magento/product-community-edition=2.1.9 --no-update
composer update --ignore-platform-reqs
0

First, try to remove the Magento through composer and then update the version. Also, check the PHP and MySQL versions before proceeding.

composer remove magento/product-community-edition --no-update
composer require magento/product-community-edition=2.1.9 --no-update
composer update --ignore-platform-reqs

For Magento 2.1.x system requirements, please follow these links. https://meetanshi.com/blog/magento-2-system-requirements/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.