0

I added a new store for chinese language. I am using Magento 1.9 When I change the store; My URL is :

http://www.********.com/app/etc/local.xml?___store=chinese&___from_store=default

I am new to Magento and no idea how to solve this problem.

Need help urgently.

2
  • store url should not contain app/etc/local.xml in it , you may have some typo in the code
    – Piyush
    Oct 3 '17 at 7:00
  • i havnt added any code. --> i added the language package in app/local. --> then created a new store and changed the Locale in configuration to the Chinese ( the other language that i am trying to add. ) Oct 3 '17 at 7:04
0

To access to your store via the code, you have to do this: www.domaine.com/?___store=chinese, chinese should be your store code <?php echo Mage::app()->getStore()->getCode(); ?>

7
  • where should i add this ? Oct 3 '17 at 8:04
  • In the url, the address bar of your browser www.domaine.com/?___store=chinese
    – Aamir
    Oct 3 '17 at 8:10
  • where should i add this--> .com/?___store=chinese&___from_store=default If i do this it works. where should i add <?php ... Oct 3 '17 at 8:34
  • No, you haven't to add the <?php echo Mage::app()->getStore()->getCode(); ?> it was just to check your store code if you want. you just need the first url
    – Aamir
    Oct 3 '17 at 8:38
  • how should i solve the error ? Oct 3 '17 at 8:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.