0

I am trying to upgrade Magento 2.1.1 to Magento 2.1.9 using following command.

composer require magento/product-community-edition 2.1.9 –-no-update

Following composer.json of root directory.

{
"name": "magento/project-community-edition",
"description": "eCommerce Platform for Growth (Community Edition)",
"type": "project",
"version": "2.1.1",
"license": [
    "OSL-3.0",
    "AFL-3.0"
],
"require": {
    "magento/product-community-edition": "2.1.1",
    "composer/composer": "@alpha",
    "mirasvit/module-search-ultimate": "^1.1"
},
"require-dev": {
    "phpunit/phpunit": "4.1.0",
    "squizlabs/php_codesniffer": "1.5.3",
    "phpmd/phpmd": "@stable",
    "pdepend/pdepend": "2.2.2",
    "fabpot/php-cs-fixer": "~1.2",
    "lusitanian/oauth": "~0.3 <=0.7.0",
    "sebastian/phpcpd": "2.0.0"
},
"config": {
    "use-include-path": true
},
"autoload": {
    "psr-4": {
        "Magento\\Framework\\": "lib/internal/Magento/Framework/",
        "Magento\\Setup\\": "setup/src/Magento/Setup/",
        "Magento\\": "app/code/Magento/"
    },
    "psr-0": {
        "": "app/code/"
    },
    "files": [
        "app/etc/NonComposerComponentRegistration.php"
    ]
},
"autoload-dev": {
    "psr-4": {
        "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
        "Magento\\Tools\\": "dev/tools/Magento/Tools/",
        "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
        "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
        "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
    }
},
"minimum-stability": "alpha",
"prefer-stable": true,
"repositories": {
    "0": {
        "type": "composer",
        "url": "https://repo.magento.com/"
    },
    "mirasvit-ssu": {
        "type": "composer",
        "url": "https://USERID:XXXX@packages.mirasvit.com/"
    }
},
"extra": {
    "magento-force": "override"
}
}

I am getting error as follow.

enter image description here

Any thing wrong while upgrading magento ?

  • Did you run "composer update" after this? – Jai Sep 29 '17 at 7:47
  • No i am trying to resolve this error. It will work properly ? – Hardik Visa Sep 29 '17 at 7:50
  • try command "composer update" and post back the outcome. – Jai Sep 29 '17 at 7:54
  • let me try but i will update magento ? did you try ? – Hardik Visa Sep 29 '17 at 7:56
  • try this. And always have backup of files and database before such updates. – Jai Sep 29 '17 at 7:57
0

The correct command is

composer require magento/product-community-edition:2.1.9 –-no-update

note the : instead of a space after product-community-edition

  • 1
    it is not working in this cases – Hardik Visa Sep 29 '17 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.