2

I have copied and pasted the file from

vendor/magento/module-checkout/view/frontend/templates/success.phtml

to

app/design/frontend/THEME/THEMENAME/Magento_Checkout/templates/success.phtml

Modified some codes in that file, then after I have

  • cleared the cache
  • removed file manually from var/view_preprocessed and pub/static

But my code won't is displayed in the frontend.

Searched already via find command for another success.phtml file but nothing found.

Any ideas to override the success.phtml page?

  • Do you use opcache in your environment ? If use opcache, you need restart opcache or disable. – St3phan Sep 28 '17 at 13:23
  • If you solved this issue then please share solution. – Jimit Bhavsar Sep 7 '18 at 6:18
0

To the following:

rm -r var/cache/* var/generation/* var/log/* var/view_preprocessed/* pub/static/_requirejs/* pub/static/adminhtml/* pub/static/frontend/* '

&

php bin/magento setup:di:compile

after this: php bin/magento setup:upgrade and php bin/magento setup:static-content:deploy

  • That's a bit overkill I guess when he's just adding a custom template. In fact php bin/magento setup:static-content:deploy should do. – Niels Sep 28 '17 at 14:56
0

Try to run these commands to set the developer mode and to regenerate all the static files.

alias mage="php -d memory_limit=-1 -f bin/magento";

mage maintenance:enable &&
mage deploy:mode:set developer &&
mage setup:upgrade &&
mage cache:flush &&
mage setup:static-content:deploy -f && 
mage setup:di:compile && 
mage maintenance:disable

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.