2

I am having a problem with, Add To Cart on both Listing page and Product page.

When I am adding a product to the cart from listing page, it's showing the cart page with no products. (see the below screen grab).

enter image description here

While adding the product to the cart from the Product page, it's showing same page in Ajax response!

Working only in Firefox

This issue I found on the local server and using localhost instance in the browser

5
  • I think the problem is with the chrome browser, isn't it ?. 1) Are you having this problem in your local machine ? 2) Are you accessing the local instance by using localhost or your local ip address ?
    – MGento
    Sep 28 '17 at 4:19
  • @MGento I have updated the question, please review it. Thanks! Sep 28 '17 at 4:30
  • This problem is also reported by others and the solution is to update the base url and secure base url in your admin. Please have a look in to the below post. magento.stackexchange.com/questions/105042/…
    – MGento
    Sep 28 '17 at 4:43
  • Try your url localhost to 127.0.0.1 from core_config_data and clear cache. Sep 28 '17 at 5:30
  • Have you found a solution to this? Having the same problem but it isn't related to the url. Just started after upgrade to 2.2.
    – Cypher909
    Oct 16 '17 at 20:37
1
change
web/unsecure/base_url
web/secure/base_url
From http://localhost/magento2community/
to http://127.0.0.1/magento2community/
0

This happened to me after updating to Magento 2.2.3 from 2.2.0.

Well, This is what worked for me.It was an issue with a Third Party Module.

Update all of your modules. If it still persists, then disable them one by one until you figure out which one is causing the issue. For me, it was one of my Amasty Modules.

Once I updated, all was good.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.