1

I've just updated our store as it hadn't been done in a while through Magento Connect.

Now when I try to access the admin area (http://www.example.com/index.php/admin) it just returns a white page.

Any advice would be much appreciated.

I believe it's Magento 1.9 but I'm not 100% sure.

  • First check the version of Magento, so that it is easy to identify. To know Magento version, please check this link: magento.stackexchange.com/questions/110453/… – Mohit Kumar Arora Sep 28 '17 at 6:47
  • I would start by flushing cache manually , id also probably rename includes folder to includesbak and then check any errors – harri Sep 28 '17 at 7:32
1

Try disabling compilation to start if the compilation was not disabled before upgrade the compiled files may have become out of sync with the Magento Version you are now currently on.

1. Disable Compilation

Shell Method

php -f shell/compiler.php -- disable

Run above command from root magento directory if you have ssh access.

OR

Via FTP

Rename the folder to includesbak or comment out the 2 lines within includes/config.php which should also disable compilation.

2. Clear Cache

rm -rf var/cache

Run above command from magento root or delete folder with ftp.

3. Check errors

Add below to index.php to show errors this may further help us rather than just guessing.

ini_set('display_errors', 1);

You can also check var/log/system.log and other log files within var/log folder for errors. Check what errors show up when you visit admin. If none of the above fix the issue then add some errors to your question found in these logs and we may have more hope figuring the real cause.

I would also recommend atleast moving that admin url to something custom to your store.

  • Thanks for your reply. 1 - Compilation was already disabled. 2 - Have cleared cache which hasn't helped. 3 - I added that line in index.php but there are still no errors showing and var/log doesn't seem to exist. – Fred Sep 28 '17 at 9:03
  • No worries let me know how it goes i had this happen once before. – harri Sep 28 '17 at 9:10
  • Maybe try reset permissions: find . -type f -exec chmod 644 {} \; find . -type d -exec chmod 755 {} \; find ./var -type d -exec chmod 777 {} \; find ./media -type d -exec chmod 777 {} \; chmod 777 ./app/etc chmod 644 ./app/etc/*.xml – harri Sep 28 '17 at 9:11
  • Make sure you have the new /app/design/adminhtml folder - I've upgraded via Magento Shell before and this folder was totally missing. – Ricky Odin Matthews Sep 28 '17 at 9:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.