1

I am not programmer, but web designer, once I made magento e-store with success.

Now I have problem with products display. They are not visible in Categories, but if I search for SKU or product name, they display, but if I click on it, there is empty page opening

HTTP ERROR 500

I have searched for solutions without success, and of course, all main settings are correct (visible, in stock, amount, correct category etc.) I use magento 1.9 and my site is with 3 languages (works ok)

Please help!

  • Check your log file and post the error. – Dinesh Yadav Sep 27 '17 at 4:36
  • Change your Visibility as Catalog, Search – Ramesh S Sep 27 '17 at 4:49
  • did you get your answer?? – Jigs Parmar Sep 27 '17 at 11:42
  • No I didn't get answer what helps – Ingrida Pērkone Sep 27 '17 at 14:29
  • Error_log file says: [27-Sep-2017 14:27:16 UTC] PHP Fatal error: Call to a member function addToChildGroup() on a non-object in /home/ingridiz/mdbaltic.ingridizains.lv/app/code/core/Mage/Core/Block/Abstract.php on line 819 – Ingrida Pērkone Sep 27 '17 at 14:38
2

Login your admin panel and goto Catalog->Manage Products select your products.

In General change your product's Visibility as Catalog, Search.

I hope it will work.

  • Visibility is Catalog,Search from beginning – Ingrida Pērkone Sep 27 '17 at 5:46
0

There should be issue of your theme!

I mean if you have used any theme, then there is possibility that the product page code is not compatible with your Magento current version?

So, please check this first!

Best of Luck...

  • I use Dresscode theme:Dresscode is premium responsive magento theme which can be used according to your needs and requirements. It includes a lot of custom features. Fully responsive, customizable, based on Sceleton CSS Framework. Compatible with magento 1.9.x, 1.8.x, 1.7.x, 1.6.x – Ingrida Pērkone Sep 27 '17 at 5:49
0

This may help!

Navigate to Admin Panel Catalog -> Manage Categories (Select the category) and navigate to Display Settings tab. Look for the option Display Mode this should be set to Product only or static Block with Products

Error Code 500 shows server error, You should check for custom redirects. that may help you.

0

The same thing happened to me once when I mistakenly set the product to a root category , i.e the default category or the category which contains all other categories. So, please check if you have got the same case.

  • No my products are connected with subcategories – Ingrida Pērkone Sep 27 '17 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.