0

When you save a customers address trough API you have the option to GetFax() and SetFax() but if i look at my backend i don't see Fax anywhere in the addresses

Anyone any idea if there is a setting or something to enable/disable that field?

enter image description here

Even though i do find that field in the database and i can SetFax() that field

-1

It is disable in database, to enable it run the following sql command

UPDATE `customer_eav_attribute` SET `is_visible` = '1' WHERE `customer_eav_attribute`.`attribute_id` = 35;

note: 35 is attribute id of Fax.

there is no option to set Fax filed in configurations

enter image description here

  • the attribute ID is not always 35. And i know how to edit the EAV attributes in the database but this is not best practice nor a solution. Thanks for the effort but can not stress enough to other people reading this then they can not run this query unless they know how the EAV attribute tables work – CompactCode May 2 '18 at 4:04
  • @SwAt.Be If you have fixed this please then share the solution. – Waqar May 2 '18 at 10:03
  • sure i will give it – CompactCode May 2 '18 at 12:25
-1

Go to Configuration->Customers->Customer Configuration->Name and Address Options and set 'Show Fax' To optional or Required

enter image description here

  • There is no such option to set "Fax" filed exist in configurations – Waqar May 4 '18 at 6:37
  • It does exist. Mr downvote. A nice big circle for you. Now check your Magento version. Update it and ssht – CompactCode May 4 '18 at 13:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.