2

I've set up multi-store with multi-domain, but I'm facing a weird issue that is default store is running perfectly but another store is not able to load CSS.

Please help

4
  • @Rafael, Please help. I am having bad day.
    – anonymous
    Sep 21, 2017 at 20:31
  • What are the error messages that are showing in the browser console? Sep 21, 2017 at 20:45
  • All stuff going to 404.
    – anonymous
    Sep 21, 2017 at 21:05
  • Yes, I've encounter one problem that i set up multi store with multi domain. I have domain folder under public_html/domain1 Also main domain pointing to magento that is public_html/magento_installation. If i exit in magento root at index.php it worked with main domain. But not exit on second domain.
    – anonymous
    Sep 21, 2017 at 21:06

2 Answers 2

1

Try to run these commands in your root installation folder using your SSH access:

alias mage="php -d memory_limit=-1 -f bin/magento"

chmod -R 775 pub/static/ var/ pub/media/ &&
rm -rf var/view_preprocessed/ var/cache/ var/page_cache/ var/tmp/ var/generation/ pub/static/frontend/ ;
mage deploy:mode:set developer;
mage setup:upgrade &&
mage setup:db-data:upgrade &&
mage dev:source-theme:deploy &&
mage setup:static-content:deploy &&
mage cache:flush &&
mage indexer:reindex;
chmod -R 775 pub/static/ pub/media/ var/
1
  • 1
    I have tried all.
    – anonymous
    Sep 21, 2017 at 20:43
3

Have you assigned the theme to the new store? if so then have you redeployed the site also reindex the data and finally flushed the cache

php bin/magento setup:static-content:deploy en_GB en_US
php bin/magento indexer:reindex
php bin/magento cache:flush
5
  • Yes i have assigned theme to store. Also verified try with upgrade and deploy command
    – anonymous
    Sep 21, 2017 at 20:23
  • did you reindex? Sep 21, 2017 at 20:24
  • Yes, I've encounter one problem that i set up multi store with multi domain. I have domain folder under public_html/domain1 Also main domain pointing to magento that is public_html/magento_installation. If i exit in magento root at index.php it worked with main domain. But not exit on second domain.
    – anonymous
    Sep 21, 2017 at 20:27
  • Have you setup your stores in your htaccess file? also if you iew the page source is it displaying the correct urls for the style sheet? Sep 21, 2017 at 20:34
  • I don't want to modify any file like index.php and .htaccess. I want to setup without editing them.
    – anonymous
    Sep 21, 2017 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.