1

With the 2.1.9 and 2.1.8, i just can't access back-office... Even on a clean install.

When i install 2.1.7, or any previous versions, all is ok. I even tried to update a project that is actually on 2.1.7, and i'm facing the same problem...

I'm on a Apache/2.4.10 + PHP 7.0.6

Does anyone faced this pb ?

Edit: it's a Magento 404 error, not an Apache one.

2
  • did you check your admin name inside app/etc/env.php Sep 21, 2017 at 16:39
  • Yep. All is ok. Sep 21, 2017 at 16:40

2 Answers 2

0

I started mine with 2.1.8 and update it using update wizard Inside the admin magento and all have been completed without any issue. Do you take a look at the php setting?

3
  • In fact, I had the pb since 2.1.8 :) But view my answer, it's just crazy. I don't understand why a clean install do that... And in my migration case, unsecure_url was not set from the beginning... and used to work without it... not since 2.1.8 ! Feb 6, 2018 at 16:04
  • Does you magento give you install success? Which panel or OS are you using?
    – westh
    Feb 6, 2018 at 19:32
  • Yep, successful install, through web, not composer. Ubuntu 16, Apache. Feb 7, 2018 at 10:09
0

The pb came from core_config_data

  • on a fresh, clean 2.2.2 install, both web/secure/use_in_frontend and web/secure/use_in_adminhtml were at NULL... Not 0, not 1, NULL... That was the pb.

  • on the project i had to migrate from 2.1.7 to 2.2.2. This time, it was the web/unsecure/base_url that was not in the table...

I don't want to understand why.

Ridiculous.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.