0

I have magento 2.1.8 and i tried to move navigation menu to the left sidebar with many different ways I found around here and on other forums but no luck so far. this is what i currently have on the default.xml:

<page xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:View/Layout/etc/page_configuration.xsd">
<body>
 <move element="catalog.topnav" destination="sidebar.main" />
    <referenceBlock name="logo">
        <arguments>
            <argument name="logo_file" xsi:type="string">images/logo.png</argument>
            <argument name="logo_img_width" xsi:type="number">320</argument>
            <argument name="logo_img_height" xsi:type="number">133</argument>
        </arguments>
    </referenceBlock>
</body>

how can i do this?

Thank you in advance!

0

Your OP is missing the content of your file. I don't have the reputation to leave a comment, so had to post this as an answer :/

| improve this answer | |
  • what is OP? sorry i am new to magento – Nick Theodoridis Sep 22 '17 at 9:43
  • Your Original Post, it was missing the line of code from your default.xml file when I first looked at the question, it appears to have it now. – codestr Sep 22 '17 at 11:52
  • Try this, <move element="catalog.topnav" destination="sidebar.main" />, taken from the answer here magento.stackexchange.com/questions/143412/… – codestr Sep 22 '17 at 11:55
  • oh silly me, sorry! thank you for your reply. I did that but it's not working. I have updated the code to the OP as it is now. I don't get it why it does pick up any move commend at all.... – Nick Theodoridis Sep 22 '17 at 12:30
  • Have you tried flushing the cache after making the changes? The layout changes will most likely not take effect until you've cleared the cache. Also, is this the default.xml for the blank theme, or for an applied theme that you have? The changes may need to go into your used themes default.xml to overwrite any changes it may be setting to the blank theme. – codestr Sep 22 '17 at 13:08
0

I found the solution, I saw this How to override the blank theme by default.xml?

and I realized that I had the default.xml file to the wrong folder!!!

this is the right one:

app/design/frontend/Amydus/test/Magento_Theme/layout/default.xml
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.