0

Firebug shows the error "Url is undefined" when I try to save a quick simple product, so nothing happens when I hit "quick create". "Create empty" and "copy from configurable" pop up as empty windows as well. I have added a screenshot- am a bit at a loss at how to go about fixing this..Any pointers are greatly appreciated!

enter image description here

4
  • How does the stack looks like (in Firebug, the top-right tab, near "Watch")? – nevvermind May 7 '14 at 13:05
  • Here's a screenshot screencast.com/t/oSaWGE9xcc – Julia May 7 '14 at 17:34
  • I've tracked down your problem to this line. That createQuickUrl property is undefined (thus your ajax URL). That property is set here, and that's where you should check for problems first. – nevvermind May 7 '14 at 22:06
  • that file was unchanged from the base file, but a search for createQuickUrl let me to another file where this was set: var createQuickUrl = superProduct.createQuickUrl;. This file was from an extension (easylife switcher), and the extension was recently updated to fix this specific bug, so I've upgraded and the problem is solved. Thanks so much for your help! – Julia May 8 '14 at 8:26
1

Problem was caused by a bug in extension easylife switcher, upgraded version at https://github.com/tzyganu/Switcher fixes the bug.

3
  • Yep...Sorry for that. I had a feeling that was causing it but wasn't sure. :) – Marius May 8 '14 at 8:34
  • I must always remember to ask "Do you have 3rd party modules?" first. – nevvermind May 8 '14 at 10:04
  • Yes sorry I had disabled them and checked but something must have gone wrong in disabling leaving me to think it wasn't the module – Julia May 8 '14 at 10:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.