0
Magento 1.9.1
Porto theme
Amasty's Full Page Cache

When going into Catalog --) Categories and trying to do something like move a category what happens is - the "Please wait" sign comes up with the circle and it takes almost 5 minutes before it goes away. It now seems to do what it suppose to and unfreezes the screen after those 5 minutes. Yesterday, it would completely freeze the screen I think.

I was getting Error messages when doing this exact thing about 3 days ago:

SQLSTATE[HY000]: General error: 1205 Lock wait timeout exceeded; try restarting transaction, query was: INSERT INTO `mg_index_process_event` (`process_id`,`event_id`,`status`) VALUES (?, ?, ?) ON DUPLICATE KEY UPDATE `status` = VALUES(`status`)


SQLSTATE[HY000]: General error: 1205 Lock wait timeout exceeded; try restarting transaction, query was: UPDATE `mg_catalog_category_entity` SET `entity_type_id` = ?, `attribute_set_id` = ?, `parent_id` = ?, `created_at` = '2015-05-29 03:04:01', `updated_at` = '2017-09-12 15:01:17', `path` = ?, `position` = ?, `level` = ?, `children_count` = ? WHERE (`entity_id`=111)


SQLSTATE[HY000]: General error: 1205 Lock wait timeout exceeded; try restarting transaction, query was: INSERT INTO `mg_index_process_event` (`process_id`,`event_id`,`status`) VALUES (?, ?, ?) ON DUPLICATE KEY UPDATE `status` = VALUES(`status`)

I cleared all Cache and re-indexed. Also restarted mySQL and Apache but it did not help.

6
  • I think your patch security updating
    – Ramesh S
    Commented Sep 15, 2017 at 12:14
  • Ramesh S: What does that mean?
    – Allysin
    Commented Sep 15, 2017 at 12:29
  • stackoverflow.com/questions/32123788/… pls refere this link
    – Ramesh S
    Commented Sep 15, 2017 at 12:29
  • magento.stackexchange.com/questions/83172/… pls refere this link
    – Ramesh S
    Commented Sep 15, 2017 at 12:29
  • Ramesh S: I've already done that (set the mode for all my indexes to 'manual') but does not seem to fix the problem - I think it's just a work-around? Not to mention I have to re-index all the time now...Is there any way to actually fix this problem?
    – Allysin
    Commented Sep 15, 2017 at 12:33

1 Answer 1

0

Since you already set your indexers to manual i would say have cron setup to reindex the site in the early morning that way you do not have to reindex as much.

0 6 * * * php -f path/to/shell/indexer.php reindexall

You would have something similar to this in your cron jobs.

3
  • danmentzer: How would I do that? Any idea why it just started to act the way it does now even though it worked properly before?
    – Allysin
    Commented Sep 15, 2017 at 20:15
  • allysin: you should be able to set up a cron job for it in your cpanel for your server. I will update my answer with an example.
    – danmentzer
    Commented Sep 15, 2017 at 20:17
  • allysin: If you need more info for setting this up I can provide references as well
    – danmentzer
    Commented Sep 15, 2017 at 20:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.