0

I am trying to update my Magento 2 to the latest version, my system fails the readiness check with the below message:

PHP Version Check Your PHP version is . The required PHP version is . Hide detail

Download and install PHP from www.php.net using this PHP Documentation.

For additional assistance, contact your hosting provider.

I understand this error might be linked to the SSL. Magento 2 by default uses ssl. I don't use ssl on my localhost and this error arises. I have to edit the config section of composer.json file in the root of magento. My composer.json must exist in this folder:

C:\xampp\htdocs\magento2\vendor\composer

It is not there. I have installed a composer file but I cannot change the .phar to .json to do the needful. Whenever I save this in .txt then in .json I get strange characters in the file like Τ�Yb �c�߶

How can I get the right composer.json file to change "disable-tls":true as per the below illustration?

Method 1: Disable-tls parameter:

"config": {
  "use-include-path": true 
  "disable-tls":false
},

Method 2: Without disable-tls parameter (delete the line):

"config": {
    "use-include-path": true,
},
2
  • What version of PHP are you running for this install, you should be running 70 or higher.
    – andy jones
    Commented Sep 15, 2017 at 9:59
  • Thanks! I am using PHP Version 5.6.31. How can I correct this?
    – Abe
    Commented Sep 15, 2017 at 13:03

1 Answer 1

1

Upgrade your php version using the following tutorial:

http://www.techflirt.com/how-to-upgrade-php7-in-xampp

1
  • Thanks! I miss one thing. I have copied the old PHP file and created a backup of that. In the same PHP folder, I have copied the most recent PHP version (7.1.8) to the current PHP folder and replaced existing files. I understand that there are two directories to be updated with new version of files, namely (php) sub-directory and (apache/bin) sub-directory, inside XAMPP installation. I cannot find the files I have to copy inside the (apache/bin) sub-directory. Where can I get those from?
    – Abe
    Commented Sep 15, 2017 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.