6

HELP!!!

Tried to upgrade Magento from 2.1.7 to 2.1.8 and now I getting below error, when I load the store.

Fatal error: Uncaught Error: Cannot instantiate interface Magento\Framework\App\Config\ConfigSourceInterface in /srv/www/vhosts/mysite/htdocs/vendor/magento/framework/ObjectManager/Factory/Dynamic/Developer.php:73

I can't do anything with the bin/magento command, it just errors with the above.

Installation steps

magento maintenance:enable
composer require magento/product-community-edition 2.1.8 --no-update
composer update
rm -rf ./var/page_cache/*
rm -rf ./var/generation/*
magento setup:upgrade
find . -type d -exec chmod 770 {} \;
find . -type f -exec chmod 660 {} \;
chmod u+x bin/magento
magento maintenance:disable
service varnish restart

I also tried

magento setup:di:compile
magento setup:static-content:deploy
service redis restart
service nginx restart

Environment

openSUSE 13.2 (Harlequin) (x86_64)
Redis 3.2.3
nginx/1.11.4
varnish-4.1.3 revision 5e3b6d2
mysql Ver 15.1 Distrib 10.0.27-MariaDB, for Linux (x86_64) using readline 5.2

Since the magento command is not working I can not restore from the backup I made before trying to upgrade. I've done many upgrades in the past year and never got this before.

Anyone have any suggestions?

  • 2
    Getting somewhere, I restarted redis assuming that would act as a flush but I needed to start redis-cli and give the flushall command. Now the magento command is working. – D. Hobaugh Sep 13 '17 at 17:40
  • 3
    All fixed. The key was to flush the redis cache – D. Hobaugh Sep 13 '17 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.