I installed fresh Magento 2.1.8.I didn't change anything. When I am trying to place an order, I noticed country field is empty in billing as well shipping section.

Checkout page - payment method step

I don't think that I am doing anything wrong.so I think it's magento's bug.

Is there anyone else see the same or I forgot something ?
And If this bug please give me some smart(without mess up core) solution.


  • I have this same problem. I'll check the Github pages for more intel on this one. Commented Sep 14, 2017 at 12:35
  • I filed an issue: github.com/magento/magento2/issues/10886 Commented Sep 14, 2017 at 12:46
  • Thanks Giel For that info.but many Magento developer I meet claims they can't see this bug. So can you tell me how you install Magento 2.1.8? setup from Command line/run setup in a browser or anything else. Commented Sep 15, 2017 at 4:05
  • Just using the browser setup, and in my configuration I only allow 1 country. Also my top destinations was set to 1 country. Commented Sep 15, 2017 at 7:29

1 Answer 1


I investigated this issue and I found in my case that this issue was caused by disabling the full_page cache on my local installation (see https://github.com/magento/magento2/issues/10886).

Could you confirm that this is the issue for you as well? If so, this could be considered a bug.

  • You are right But I can't enable cache during development so I am going to just ignore it. :( Commented Sep 15, 2017 at 11:55
  • I am using Magento 2.4.4 EE version, the full_page cache is in enabled stage, but still the country is not showing on checkout page shipping address section. Note : After refresh 2 to 3 times, then the country will appeared.
    – senthil
    Commented Oct 12, 2022 at 7:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.