1

We are trying to Migrate Magento 1.7.x to 2.1.x data migration using the Magento Data Migration Tools Script.

below errors are display,

[2017-09-06 14:00:03][INFO][mode: data][stage: integrity check][step: EAV Step]: started

[2017-09-06 14:00:03][INFO][mode: data][stage: integrity check][step: Customer Attributes Step]: started

[2017-09-06 14:00:03][INFO][mode: data][stage: integrity check][step: Map Step]: started

[2017-09-06 14:00:06][ERROR]: Source documents are not mapped:

[2017-09-06 14:00:06][ERROR]: Source documents are not mapped: addtocart_device,addtowishlist_device,banners,banners_store,bannerslider,core_directory_storage,ebizmarts_ecomm360,ebizmarts_mailchimppro,elasticemail_transaction,gtspeed_image,gtspeed_stat,ibanners_banner,ibanners_group,interaktingslider_slide,interaktingslider_slide_position,interaktingslider_slide_store,m_attribute,m_db,m_db_log,m_edit_session,m_filter,m_filter2,m_filter2_store,m_filter2_value,m_filter2_value_store,m_filter_datetime,m_filter_decimal,m_filter_int,m_filter_text,m_filter_varchar,magazento_socialgp,magebuzz_testimonial,magenotification,magenotification_extension_feedback,magenotification_extension_feedbackmessage,magenotification_log,mobicommerce_applications2,mobicommerce_applications_settings2,mobicommerce_category_icon2,mobicommerce_category_widget2,mobicommerce_devicetokens,mobicommerce_licence,mobicommerce_notification,mobicommerce_widget2,mobistorelocator_holiday2,mobistorelocator_image2,mobistorelocator_location2,mobistorelocator_rating2,mobistorelocator_specialday2,mobistorelocator_store2,mobistorelocator_store_value2,mobistorelocator_storereviews2,neotheme_blog_category,neotheme_blog_comment,neotheme_blog_post,neotheme_blog_tag,payucheckout_api_debug,plumbase_product,pricecalculator,pricecheck,pws_productqa,qaz_qbanner,qaz_qbanner_category,qaz_qbanner_image,qaz_qbanner_page,qaz_qbanner_store,slide,snippet,themeswitcher_theme,themeswitcher_theme_browser,themeswitcher_theme_platform,twlogin_customer2,web,widgento_login

[2017-09-06 14:00:06][ERROR]: Source fields are not mapped. Document: catalog_product_option. Fields: regex,regex_message,validators

[2017-09-06 14:00:06][ERROR]: Source fields are not mapped. Document: catalogrule. Fields: attribute_to_select

[2017-09-06 14:00:06][ERROR]: Source fields are not mapped. Document: catalogrule_product. Fields: attribute_to_select

[2017-09-06 14:00:06][ERROR]: Source fields are not mapped. Document: sales_flat_order. Fields: onestepcheckout_customercomment,orderfromplatform

[2017-09-06 14:00:06][ERROR]: Source fields are not mapped. Document: sales_flat_order_item. Fields: frame_img1,frame_img2,frame_img3,frame_img4

[2017-09-06 14:00:06][WARNING]: Mismatch of data types. Source document: catalogrule_product. Fields: action_operator

[2017-09-06 14:00:06][WARNING]: Mismatch of data types. Destination document: catalogrule_product. Fields: action_operator [2017-09-06 14:00:06][INFO][mode: data][stage: integrity check][step: Url Rewrite Step]: started

[2017-09-06 14:00:06][INFO][mode: data][stage: integrity check][step: Log Step]: started

[2017-09-06 14:00:06][INFO][mode: data][stage: integrity check][step: Ratings Step]: started

[2017-09-06 14:00:06][INFO][mode: data][stage: integrity check][step: ConfigurablePrices step]: started

[2017-09-06 14:00:06][INFO][mode: data][stage: integrity check][step: OrderGrids Step]: started

[2017-09-06 14:00:06][INFO][mode: data][stage: integrity check][step: Tier Price Step]: started

[2017-09-06 14:00:06][INFO][mode: data][stage: integrity check][step: SalesIncrement Step]: started

[Migration\Exception] Integrity check failed

We are getting this errors, while run the config.xml file. Anyone please review the issues and let me know your suggestions to fixes the issues.

2

Your errors are self explanatory. Did you read the migration documentation?

I'll try to guide you in the right direction:

As you can see, your old M1 Database contains a lot of extra tables or fields for custom modules. For example:

  • ebizmarts_mailchimppro
  • interaktingslider_slide
  • mobicommerce
  • twlogin

to mention a few.

Now, from the documentation:

Some Magento 1 entities (in most cases, coming from extensions) 
do not exist in the Magento 2 database.

This message appears because the Data Migration Tool runs internal 
tests to verify that tables and fields are consistent between 
source (Magento 1) and destination (Magento 2) databases.

So you either install the M2 versions of the modules, or you tell the migration tool to ignore all the unmapped documents or fields by editing your map.xml file. Read the documentation as to where to configure which map file is used for your magento 1 version.

Then ignore all the fields and tables, for example:

<ignore>
  <document>addtocart_device</document>
</ignore>

and

<ignore>
   <field>catalogrule.attribute_to_select</field>
</ignore>

If tables or fields are called differently in M2, you can rename tables or move fields by using eg:

<rename>
  <document>sales_flat_quote_item</document>
  <to>quote_item</to>
</rename>

and

<move>
  <field>catalog_category_entity_varchar.entity_id</field>
  <to>catalog_category_entity_varchar.row_id</to>
</move>

respectively.

--- edit as per comment:

Example error:

[2017-09-06 14:00:06][ERROR]: Source fields are not mapped. Document: sales_flat_order. Fields: onestepcheckout_customercomment,orderfromplatform

Fix:

<ignore>
   <field>sales_flat_order.onestepcheckout_customercomment</field>
</ignore>
<ignore>
   <field>sales_flat_order.orderfromplatform</field>
</ignore>
  • thanks for your suggestion. below are the recent migration error logs kindly check that and let us know ur suggestion. > [2017-09-07 07:29:04][ERROR]: Destination documents are not mapped: sales_flat_order ......... > [2017-09-07 07:29:04][INFO][mode: data][stage: integrity check][step: SalesIncrement Step]: started – udhayakumar Sep 7 '17 at 7:37
  • @UDHAYAKUMAR I've given you the answer. Edit your map.xml file and try to add one document (table) to be ignored and you will see it disappear from your error log when trying to migrate again. Work through it until none are 'unmapped'. – tecjam Sep 7 '17 at 7:39
  • i followed in your comment ignored sales_flat_order and again run the command below error to be display, [2017-09-07 07:44:25][ERROR]: Document has ambiguous configuration: sales_flat_order – udhayakumar Sep 7 '17 at 7:45
  • @UDHAYAKUMAR: Please update your post with the exact lines you put into your map.xml file. I will briefly updated my answer with the example of how to ignore the 2 fields in the sales_flat_order table - you can't ignore the full table as you need it. – tecjam Sep 7 '17 at 9:47
  • <ignore> <document>sales_flat_order</document> </ignore> - this is wat we added in map.xml. Kindly let me know ur suggestion. – udhayakumar Sep 7 '17 at 9:52
0

Add the missing table in map.xml

    <ignore>
        <field>email_abandoned_cart</field>
    </ignore>
    <ignore>
        <field>temando_collection_point_search</field>
    </ignore>
    <ignore>
        <field>temando_order_collection_point</field>
    </ignore>
    <ignore>
        <field>temando_quote_collection_point</field>
    </ignore>

and Run

php bin/magento migrate:settings --**reset** /var/www/html/YOUR_ROOT_PATH/vendor/magento/data-migration-tool/etc/opensource-to-opensource/1.9.3.4/config.xml

after not complete so run ----------------------------(auto)

php bin/magento migrate:settings --**auto** /var/www/html/YOUR_ROOT_PATH/vendor/magento/data-migration-tool/etc/opensource-to-opensource/1.9.3.4/config.xml

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.