5

Once per day I got my production server down with this error

Notice: Undefined index ....vendor/magento/module-developer/Model/View/Page/Config/RendererFactory.php on line 64

I've checked config for dev/front_end_development_workflow/type and it exists in database also and as default config in xml. Magento version 2.1.7

This error fixes with clearing cache but it's not a solution to do every time. Does anybody faced with this issue?

3
  • i have the same issue , any idea? – CompactCode Sep 19 '17 at 19:56
  • I am having the same issue, are you running a multi-site setup? are you running with Redis? – Andrew C. Stayart Sep 22 '17 at 20:51
  • Nag Kernez, did you have any luck resolving this issue? I'm experiencing the same error and am curious how you solved it. – Richard Tuin Jan 15 '19 at 10:00
2

You can find the fix here :

https://github.com/magento/magento2/issues/8619

It worked for me and that is to set the compiling to server side less compilation and then deleted the row (for some reason).

After that re-run php bin/magento setup:upgrade

You can find the setting in : Stores->Configuration->Advanced->Developer-> turn to default settings scope -> Front end workflow

0

1) open PHPMyAdmin

2) select your database

3) go to core_config_data file

4) run this query

UPDATE `magento`.`core_config_data` SET `value` = '0' WHERE core_config_data`.`config_id` = 5;

5) and also

UPDATE `magento`.`core_config_data` SET `value` = '0' WHERE `core_config_data`.`config_id` = 6;

It works definitely!

2
  • 1
    I would never trust the config_id value to point to a specific configuration parameter, I would use the path. – Tero Lahtinen Jun 5 '18 at 6:58
  • you can run this command : php bin/magento setup:di:compile and then refresh the frontend page , it's works – Ashish Jun 5 '18 at 7:22
0

To see the correct error message, try to switch on developer mode "bin/magento deploy:mode:set" and disable all cache

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.