I have imported ~17k products, and when reindexing the catalogsearch_fulltext index does not complete. I have tried resetting and reindexing with

php bin/magento indexer:reset catalogsearch_fulltext
php -d memnory_limit=-1 bin/magento indexer:reindex

The process starts, but appears to fail without any warning/error. If I run reindex again, it returns

Catalog Search index is locked by another reindex process. Skipping.

I cannot see any locks in the database.

Is there another way to force this to reindex?


You need run command bin/magento indexer:reset catalogsearch_fulltext and then start reindex again.

  • I have done that, as stated in my question. When it kicks off, it just seems to stop. – Stuart Hoff Sep 4 '17 at 14:21

Upgrading to 2.1.8 allowed me to re-index successfully

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.