0

It seems my server cannot be upgraded as my magento website 1.9.2.2 is not compatible with PHP 7.0. My web developers say that there are plugins available but they do not recommend this? HELP......

2

Then don't use PHP7? Magento 1 is not compatible with PHP7. Inchoo's module can help https://github.com/Inchoo/Inchoo_PHP7 but in the end you would need a developer to help port needed modules to PHP7 for you.

The performance is worth it, though.

0

Magento 1.x is not by default compatible with PHP 7, but with minor modifications, it becomes compatible with PHP 7.

Since PHP 7 is far better than PHP 5.x in terms of performance and security, you can upgrade your PHP version.

There are many tutorials available to make Magento 1.x compatible with PHP 7.

Please let me know if you have any question or concern.

0

Can report no problems using the Inchoo_PHP7 module and 1.9.2.4 for the past 6 months or so. the only issue you may face is any ioncube encoded extensions, there were issues with this and PHP7 a while back, but there's a plugin for that now. It's possible to install php5.6 and php7.0 together on the same server using ppa. You can then switch between the two in nginx. See: https://askubuntu.com/questions/756181/installing-php-5-6-on-xenial-16-04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.