2

I'm currently facing an issue with regards to upgrading Magento from 2.1.3 to 2.1.8.

Unfortunately, My ISP refuses to run commands on their shared hosting server as this affect other clients as well so I've opted to use the admin interface:

System > Tools > Web Setup Wizard

And run the setup but getting numerous errors.

Here is readiness check fails errors:

Readiness Check

I've logged in to my CPanel and set up the cron jobs like this:

/usr/local/bin/php /home/username/public_html/bin/magento cron:run | awk '{ print strftime("\%Y-\%m-\%d \%H:\%M:\%S"), $0; fflush(); }' 2>&1 >> ~/magento_cron.log
/usr/local/bin/php /home/username/public_html/update/cron.php | awk '{ print strftime("\%Y-\%m-\%d \%H:\%M:\%S"), $0; fflush(); }' 2>&1 >> ~/magento_cron.log
/usr/local/bin/php /home/username/public_html/bin/magento setup:cron:run | awk '{ print strftime("\%Y-\%m-\%d \%H:\%M:\%S"), $0; fflush(); }' 2>&1 >> ~/magento_cron.log

But this has not lead to any success. Upgrading my PHP version is a minor issue but could someone please be so kind as to advice what I could potentially be doing wrong?

Any advice would be greatly appreciated.

  • You can upgrade by CLI. – Suresh Chikani Sep 4 '17 at 9:30
  • Are you trying upgrade to magento2.18 – shivashankar m Sep 4 '17 at 9:35
  • If you want to use the Setup Wizard, you have to determine why the cron readiness check is failing, too. Check the cron recommendations in the official docs and compare them to what you have on your server. But as others have mentioned below, the command line upgrade should be easier. – MartyS Magemojo Support Sep 4 '17 at 9:46
  • I am busy troubleshooting why there are a problem with the cron jobs and I am comparing them to the official documentation. CLI would be much easier but my ISP refuses to run the upgrade command. @MartySMagemojoSupport – Vin_Ny Sep 4 '17 at 12:01
  • @SureshChikani Unfortunately I don't have any access to SSH or CLI. – Vin_Ny Sep 4 '17 at 12:01
3

Steps to Upgrade:

step1:install the composer:

step2:remove the cache, page_cache and generation from magento var

step3:composer require magento/product-community-edition 2.1.8
--no-update

step4:composer update

Then follow the links:

php bin/magento cache:flush

php bin/magento setup:upgrade

php bin/magento setup:di:compile

php bin/magento indexer:reindex
2

You can upgrade from CLL. Run below commands in Root of your magento installation:

   composer require magento/product-community-edition 2.1.8 --no-update
    composer update
    rm -rf var/di var/generation
    php bin/magento cache:flush
    php bin/magento setup:upgrade
    php bin/magento setup:di:compile
    php bin/magento indexer:reindex

It works smoothly. Detail Documentation

  • Thank you so much, this is the route I planned on taking, but my ISP won't run any of these commands as they are considered 'unsafe' and they will affect all of the other clients on the shared hosting platform. – Vin_Ny Sep 4 '17 at 12:05
  • Ok, but CLI is best/easy option because you will have lot of problem in admin interface for simple task. If possible, try to get access OR send Commands to server-support to execute these commands on your root magento installation. – Jai Sep 4 '17 at 12:49
  • You are 110% correct. Send through these commands to the server support who came back and said they're unsafe :/ only option will be to move hosting providers. – Vin_Ny Sep 4 '17 at 13:20
2

update using CLI

php bin/magento --version >> to know version

  1. php composer.phar require magento/product-community-edition 2.1.8 --no-update

    composer require magento/product-community-edition 2.1.8 --no-update

  2. php composer.phar update

    composer update

  3. Clean cache, and di and generation folders.
  4. bin/magento setup:upgrade
  • Thank you for this but unfortunately I can't upgrade using CLI. Will try and get my ISP to only run the upgrade commands as I can clear those folders manually. – Vin_Ny Sep 5 '17 at 10:10
0

It worries me how the hosting has been set up, as it means the websites are not self contained, and one being hacked could lead to the whole server being compromised. If you are running an e-commerce business then I'd suggest moving provider if/when you can.

  • Palmer Site is an eComm site but it's on a shared hosting server so it's not self-maintained – Vin_Ny Sep 5 '17 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.