6

Just noticed today that First Class Package no longer works and won't quote customers for shipments under 16oz.

Looks like the USPS changed their API for First Class to First-Class Package Service - Retail from First Class Mail Package according to the USPS debug log file. 0_FCP was resulting in the wrong description so First Class USPS wasn't being offered to customers.

Edited app/code/core/Mage/USA/Model/Shipping/Carrier/Usps.php

line 703

was: 'First-Class Mail Parcel' => '0_FCP',
now: 'First-Class Package Service - Retail' => '0_FCP',

Now USPS First Class is again being offered to customers. Leave 'First Class Mail Parcel' highlighted in Admin so the service is correctly calculated and offered as only this selection uses 0_FCP. Your customers will now see First Class Package Service - Retail when First Class Package is offered. Also, be sure to clear /var/cache or your Magento cache in Admin if the results don't appear. Sorry, can't assist with Magento2.

Has anyone else tested for this issue (it did not exist yesterday during checkouts) which appeared this morning?

Also wondering why this occurred and if I missed anything in the file edit.

EDIT: Bad news is my fix will only pull First Class package rates for 12oz max (retail), however commercial discounted rates (if you use a PC Postage Product eg. Stamps or Endicia) which maxes out at 16oz is unavailable. This service will be named: 'First-Class Package Service - Commercial' which Magento doesn't have a code for. So, here's the current situation:

  • If you don't use the fix above, you can't display or retrieve First Class Package rates for your customers

  • If you use the fix above, anything over 12oz will use Priority Mail rates and First Class rates will not appear in your cart

Currently there is no way to pull USPS First Class Priority Commercial rates using Magento.

Not sure if Magento is aware of this or if/when this will be fixed.

  • I'm having same issue. I overwrote that file in code/local, but still not seeing first class parcel rate on frontend. – frshjb373 Aug 31 '17 at 19:50
  • additionally, I'm seeing in Magento 2 .git that the name for the first class rate is still "First-Class Mail Parcel." I figure that would have been updated on latest version if the name has changed: github.com/magento/magento2/blob/develop/app/code/Magento/Usps/… – frshjb373 Sep 1 '17 at 15:41
2

To clarify on answer provided in original question, I was able to resolve issue by overwriting core file from:

app/code/core/Mage/USA/Model/Shipping/Carrier/Usps.php

and copied file to:

app/code/local/Mage/USA/Model/Shipping/Carrier/Usps.php

by editing line 703 per original questions posted in this thread:

was: 'First-Class Mail Parcel' => '0_FCP',
now: 'First-Class Package Service - Retail' => '0_FCP', 

This includes more information about the renaming of this shipping method: Federal Register

I've submitted bug report to Magento team, you can also follow that here: https://magento.com/tech-resources/bug-tracking/issue/index/id/1762/

Official fix from Magento here: https://magento.com/tech-resources/bug-tracking/issue/index/id/1762/

  • I feel like updating the core file would be OK in this situation. If/when Magento releases a patch affecting this file, or if you upgrade to a newer version of Magento, then your local codepool override will mask any code changes in the core file. – kmdsax Sep 7 '17 at 16:39
  • Yes, completely agree...that is if Magento continues to support M1...which I read a while back that was ending very soon. – frshjb373 Sep 7 '17 at 22:04
  • @frshjb373 Can i get help about USPS Media mail -> magento.stackexchange.com/q/227667/57334 – zus May 28 '18 at 4:59
1

You can find workaround here: http://devdocs.magento.com/guides/v2.1/release-notes/tech_bull_USPS-patch-Sept2017.html

0

There is some information here - http://blog.shipperhq.com/2017/09/usps-api-changes-sept-1st-2017/

  • Also there is another entry on line 543 – Neal Hart Sep 4 '17 at 18:42
0

I'm unable to fix this running Magento 2.1.5 I tried following the instructions at

http://blog.shipperhq.com/2017/09/usps-api-changes-sept-1st-2017/

for Magento 2.0 but I don't have the file they refer to. I don't have "vendor/magento/module-usps/Model/Usps.php"

I do have "vendor/magento/module-usps/Model/Carrier.php" and it seems to have some of the same code and I tried changing that file as per those instructions and it doesn't fix the problem for me.

Does anyone have working instructions for this workaround using Magento 2.1.x?

0

The /USA/ folder in given directory should be written just w/ capital 'U' and lowercase 'sa' so it should be:

Copy from: app/code/core/Mage/Usa/Model/Shipping/Carrier/Usps.php

Create directory and paste edited version to: app/code/local/Mage/Usa/Model/Shipping/Carrier/Usps.php

Otherwise its not recognized by system (at least in my 1.9.3.6 Magento version)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.