0

I have installed a fresh Magento2 but style sheet is not loading and When I check the page source, the style sheet isn't there, and of course, the page looks terrible:

http://unisolinternational.magemojo.io/

It has the ClickBoom theme by Magentech, and I used their "quickstart" to install Magento and the theme all at once.

Here's what I've already tried:

  • deployed content, set the pub
  • directory to 777` confirmed I have a "/" at the end of the URL
  • replaced the .htaccess files with sample .htaccess files.

I appreciate any suggestions you can provide.

0

If you are facing problem of css and js page load design after installation in magento2

please follow the following step-:

open the terminal and navigate to magento web root

  $ cd /var/www/html/magento2

Step 1.

  $ php bin/magento setup:static-content:deploy

Step 2.

  $ php bin/magento indexer:reindex

Step 3.

  make sure apache “rewrite_module” is enable and then restart the server

Step 4.

   $ chown -R www-data:www-data /var/www/html/magento2

Step 5.

   $ chmod -R 775 /var/www/html/magento2/ 
   $ chmod -R 777 /var/www/html/magento2/var/
   $ chmod -R 777 /var/www/html/magento2/pub/

Step 6.

  delete cache folder under var/cache

The above step working. I hope this will work for you also.

You can check following useful links aswell: answer is already given there.

Magento 2 CSS and JavaScript not loading from correct folder

http://devdocs.magento.com/guides/v2.0/install-gde/trouble/tshoot_no-styles.html

https://community.magento.com/t5/Installing-Magento-2/CSS-not-loading-in-the-front-and-backend-after-installing-via/td-p/22786

  • Thank you for that advice. Unfortunately, I don't have the option to restart the server, because the website is on shared hosting. – Michael Lipsky Aug 31 '17 at 17:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.