4

I've the error.

There was no Home CMS page configured or found.

On the magento website homepage, I've tried to clean the cache, reindex, run the command setup:upgrade but still got the error.

4 Answers 4

5

Check if the page that you choose for the home page have the store view included in the option PAGE IN WEBSITE.

Content > Pages> Home(or the name of your home page) > Edit > Page in website

2
  • Your answer inspired me, The solution was changing the default store of the website to be my current default demo.
    – AboElnouR
    Commented Jul 9, 2019 at 20:29
  • worked Thanks ..! Commented Jun 9, 2020 at 11:26
2
Store > Configuration > General > Web > Default Pages > CMS Home Page

Try to clear your Magento Cache. And, make sure that this config is for your current storefront. Please, check the config for current store view.

Also, check that assigned CMS Home Page Store view setting.

1
  • I've checked, all correct but still the error Commented Aug 31, 2017 at 18:52
0

Here what works with me on Magento 2.3.1

Go to

Store > All stores

Then choose your website and change Default Store to the default demo that you have chosen in:

Store > Configuration > General > Web > Default Pages > CMS Home Page
0

We had bilingual hiring done through Envato. Now we get the message "There was no Home CMS page configured or found." when we switch to Rubix 2 in System and Content. We pay the customization, because we have chosen the template because of the good and beautiful category display.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.