As topic states, the PayPal Express button is visible on both minicart and cart pages. The button works just fine.

On the checkout page, however, there is no PayPal option.

Settings are as follows:

paypal settings 1 paypal settings 2 Enable PayPal Guest Checkout: No
Require Customer's Billing Address: No
Billing Agreement Signup: Never
Skip Order Review Step: Yes

magento_paypal is enabled magento_payment is enabled

Nothing present in debug.log, exception.log, or system.log, error console to indicate a problem.

No modules have been installed that would modify or interfere with PayPal.

It has worked in the past. The problem first showed up when I changed Transfer Shipping Options to Yes then back to No again.

I've tried clearing my local browser cache, deleting cookies, reentering PayPal credentials. On the server setup di:compile, setup:deploy-static-content, setup:upgrade, disabling and reenabling magento_paypal and so far nothing has fixed.

My staging server, with near-identical PayPal express settings works just fine. The only difference on that server is it uses Sandbox credentials. Any ideas?

CE Magento 2.1.8 running Apache 2.4.18 on Ubuntu 16.04, php 7.0.22

1 Answer 1


I have the same issue, nearly at the same time.

I noticed after making an extensive debug with the JS code that the render of the method is not getting the template/layout.

I'm investigating further to see if I can get a solution for this matter.


After changing the option "Billing Agreement Signup" to "Yes", the option appeared for me.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.