We are using Magento 2.1.8 and believe this worked in Magento 2.1.7 (but the bug may also been introduced sometime else).

When clicking a filter in the shop category, we get the message "We can't find products matching the selection."

We already reindexed and cleared the cache.

We use the Wyomind_ElasticSearch module but already disabled it and have the same result. But after enabling it back and reindexing, we sometimes see one product (which should be more) in the filtered category. Interestingly, the product count shows "4 items", even only 1 is shown.

How can this be debugged?

3 Answers 3


I've the same problem and at the moment I'm working on it.

As a quick fix, I changed the following line :

    ['cpa' => $attribute->getBackend()->getTable()],                                                                                                                         
    'cpe.' . $aiField . ' = cpa.' . $aiField,                                                                                                                                
    ['store_id', 'value'] 

with the following :

    ['cpa' => $attribute->getBackend()->getTable()],                                                                                                                         
    'cpe.' . $aiField . ' = cpa.' . 'row_id' //$aiField,                                                                                                                                
    ['store_id', 'value']

And it's working fine. If I'll not find any collateral error I'll create a module to avoid to edit core files.

The file is vendor/magento/module-catalog/Model/ResourceModel/Product/Collection.php and the line 1037

The problem I'm trying to fix at the moment is related with the filters in the category page which for some reason is not showing any product.


I have found a solution in another question https://magento.stackexchange.com/a/190817/81

It seems to be a bug in 2.1.8


We had the same issue after upgrading to 2.1.8 from 2.1.7 the filters would return no results and this is how we fixed it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.