4

I upgraded from 2.1.7 to 2.1.8 but since the upgrade, PayPal Express no longer shows as a method of payment on the checkout page.

I've re-entered all API, switched to default theme, tried reinstalling the PayPal module, tried about every single PayPal option, made sure no conflicts with Braintree, made sure all other PayPal methods were disabled, but once on the payment screen, PayPal is not an option for payment.

I can get the buttons to show on all category pages, product page and even the cart. It's on the step 2 of one page checkout where there's no PayPal option for payments.

It is a multistore setup and it doesn't work on either site. I'm clueless at this point and read the dev, but it didn't mention anything about new PayPal settings, at least that I'm aware of. Any insight is greatly appreciated.

  • Have you check magento log file? – Dhiren Vasoya Aug 23 '17 at 10:13
  • I have, but not sure what it means [2017-08-23 15:27:29] main.INFO: Add of item with id Magento_Paypal::report_salesroot_paypal_settlement_reports was processed [] [] [2017-08-23 15:27:29] main.INFO: Add of item with id Magento_Paypal::paypal_billing_agreement was processed [] [] – dawhoo Aug 23 '17 at 15:42
  • facing the same issue and working on it please update me if you solve it from your end. – Codrain Technolabs Pvt Ltd Aug 25 '17 at 10:09
  • I am using 2 stores. Don't know if that's the same for others or not. Still no luck with PayPal so far. – dawhoo Aug 31 '17 at 20:21
2

Although the questions is asked more than a year ago it is pretty difficult to find a good answer for this issue. Let me help people save time in the future who look for an answer too.

It seems that since version 2.1.8 there has been introduced a bug which makes a working/configured Paypal payment option disappear (or not show up in the first place) from the checkout page. The solution is to set the enabled option to yes of the PayPal Billing Agreement section. This wil make sure Paypal will be visible (agian).

enter image description here

0

OK, found the answer.

Go to this file

app/code/Magento/Paypal/view/frontend/layout/checkout_index_index.xml

Add this code to line 32

<item name="paypal_express" xsi:type="array">
      <item name="isBillingAddressRequired" xsi:type="boolean">true</item>
</item>

Then run the upgrade commands via SSH and PayPal is back and working.

php bin/magento setup:upgrade

php bin/magento cache:flush

php bin/magento indexer:reindex

php bin/magento deploy:mode:set production -s

php bin/magento setup:di:compile

php bin/magento setup:static-content:deploy
  • The default option value should be false but not true. This option is responsible to create billing form js component, PayPal Express Checkout doesn't have it. Related Github issue github.com/magento/magento2/issues/12878 – joni jones Dec 27 '17 at 10:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.