0

Now the site doesn't show and we get the following Error on the home page

Exception: Notice: Use of undefined constant ICONV_IMPL - assumed 'ICONV_IMPL' in /home/tassosco/public_html/vendor/magento/framework/Stdlib/StringUtils.php on line 162 in /home/tassosco/public_html/vendor/magento/framework/App/ErrorHandler.php:61 Stack trace: #0 /home/tassosco/public_html/vendor/magento/framework/Stdlib/StringUtils.php(162): Magento\Framework\App\ErrorHandler->handler(8, 'Use of undefine...', '/home/tassosco/...', 162, Array) #1 /home/tassosco/public_html/vendor/magento/framework/HTTP/Header.php(120): Magento\Framework\Stdlib\StringUtils->cleanString('Mozilla/5.0 (X1...') #2 /home/tassosco/public_html/vendor/magento/framework/HTTP/Header.php(57): Magento\Framework\HTTP\Header->_getHttpCleanValue('HTTP_USER_AGENT', true) #3 /home/tassosco/public_html/vendor/magento/framework/App/Response/HeaderProvider/XssProtection.php(43): Magento\Framework\HTTP\Header->getHttpUserAgent() #4 /home/tassosco/public_html/vendor/magento/framework/App/Response/HeaderManager.php(42): Magento\Framework\App\Response\HeaderProvider\XssProtection->getValue()

5 /home/tassosco/public_html/vendor/magento/framework/Interception/Interceptor.php(123):

Magento\Framework\App\Response\HeaderManager->beforeSendResponse(Object(Magento\Framework\App\Response\Http\Interceptor))

6 /home/tassosco/public_html/var/generation/Magento/Framework/App/Response/Http/Interceptor.php(117):

Magento\Framework\App\Response\Http\Interceptor->___callPlugins('sendResponse', Array, Array) #7 /home/tassosco/public_html/vendor/magento/framework/App/Http.php(185): Magento\Framework\App\Response\Http\Interceptor->sendResponse() #8 /home/tassosco/public_html/vendor/magento/framework/App/Http.php(156): Magento\Framework\App\Http->handleDeveloperMode(Object(Magento\Framework\App\Bootstrap), Object(Exception)) #9 /home/tassosco/public_html/vendor/magento/framework/App/Bootstrap.php(263): Magento\Framework\App\Http->catchException(Object(Magento\Framework\App\Bootstrap), Object(Exception)) #10 /home/tassosco/public_html/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http))

11 {main}

please help me?

1

You have to go into your php.ini file and uncomment this

[iconv]
;iconv.input_encoding = ISO-8859-1
;iconv.internal_encoding = ISO-8859-1
;iconv.output_encoding = ISO-8859-1

So that it looks like this

[iconv]
iconv.input_encoding = ISO-8859-1
iconv.internal_encoding = ISO-8859-1
iconv.output_encoding = ISO-8859-1

Also change this

;intl.error_level = E_WARNING

Into this

intl.error_level = 0

And make sure you have installed php extensions: php-iconv and php-intl, then restart apache.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.