I'm running a magento 1.9 fresh install in a Debian 9 (also fresh install) and I can't find the "Template Settings". It should be under System > Configuration > Advanced > Template, but it is not there.

I'm looking for this section to set the "Allow Symlinks" to On, but it is not there. Anyone can help me?

Thanks in advance.


1 Answer 1


Since Magento / SUPEE-9767 symlinks are disabled (and config option is hidden) by default. You can only change it on DB at the moment:

Either ...

UPDATE core_config_data SET value = '1' WHERE path = 'dev/template/allow_symlink';

Or if entry does not exist ...

INSERT INTO core_config_data (config_id, scope, scope_id, path, value)
VALUES (NULL , 'default', '0', 'dev/template/allow_symlink', '1');

Note: Don't forget to add table prefix if you use one.

Or run this from magento root ...

Mage::getConfig()->saveConfig('dev/template/allow_symlink', '1', 'default', 0);

Not the answer you're looking for? Browse other questions tagged or ask your own question.