0

I have two sites, one of which has the customer quick access bar (shown below) showing on all pages, the other doesn't have this and I can't find it in the settings on the magento dashboard so assume I will have to edit a .phtml file?

enter image description here

Any help would be much appreciated!

Thanks.

0

The most obvious issue would be that:

  1. The second theme is missing the following from app/design/frontend/theme/default/template/page/html/header.phtml:

    echo $this->getChildHtml('topLinks')
    

Adding it will in turn add the relevant information from the instantiated Mage_Page_Block_Html_Header class.

Here you can see the default positioning (line 40):

Github: magento-mirror/app/design/frontend/base/default/template/page/html/header.phtml

Other than that, you can also:

  1. Ensure that app/design/frontend/theme/default/layout/page.xml doesn't deviate from the native Magento file (or at least contains the essentials, you can use a text-comparison application like https://text-compare.com/)

  2. Ensure that app/design/frontend/theme/default/page/html/top.links.phtml is properly in place.

  • Hi, the original header.phtml file contains this line of code. I also tried replacing the header.phtml file with the one in the link but this didn't work. Thanks anyway. – user55794 Aug 15 '17 at 13:06
  • Edited the answer to include 2 additional points of reference worth looking into. – Moose Aug 15 '17 at 13:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.