0

I have manually added 400 products in Magento 2.1.7 CE via the backend. There are configurable products involved, their associated simple products, and normal simple products (not associated with configurable products).

I am exporting all products via System->Export and start examining the csv file. First thing is that in configurable_variations column, not all attributes used for skus associated with each configurable product are in the exported file. I add those manually. i.e. only color was listed for some products-skus with color and size: I added size as well and vise versa.

Second I need to add these products into 2 different store views (languages -el - en) already created in the backend. Categories, attribute sets etc. are already created too. All exported fields are involved in the import. Simple products come first in the file, second are simple products associated with configurable and configurable products are last for both store views (800 entries).

I am trying to update products (Add/Update mode), no luck. I manually delete all products and try to import: "Import successfully done", but no products imported. No errors, no logs. I've tried to completely remove description and short description fields, in case improper characters are involved, no luck.

I am convinced I miss something and it's me learning. But is it a typo? how to identify what is wrong in this csv file which is large - not just 2 test products? I have gone through this carefully: https://goo.gl/erH7aQ and have made many updates. I am not sure what is wrong anymore.

Update

Thanks Rajkumar .E. ..basic knowledge: Started with one simple product then a few more, etc and found some problems mainly in Categories. Importing Configurable products is not the most straight forward thing at first, but import works. Last import attempt was still giving "errors" (maybe on something not very important) but also "import successfully done" and data imported. I set "Stop on Error" and Allowed Errors Count to 410

Update

In my case, there was 49 products only and Import was successfully done but, no products were added even after clearing cache and doing re-index. I have recently updated our magento version to 2.2.5 (Community Edition).

I have also tried with removing special character from the CSV but still no success. Let me know if I have to re-post this issue or is there any solution for this.

enter image description here

  • after Import successfully done can you check admin->products->catalog any product are there – Rajkumar .E Aug 5 '17 at 4:24
  • I checked multiple times. I have reindexed. No products in admin->products->catalog. – spap13 Aug 5 '17 at 12:10
  • create one csv file with one simple product, Then import, after check it. and also use Import Behavior as a Stop on Error – Rajkumar .E Aug 5 '17 at 12:28
  • hi have you find any solution to this.Plz help me I am facing same problem – Bibhu Asish Feb 21 '18 at 12:55
  • did you reindex the site? I also have same issue, if I enter 1000 product only show 10 etc. I saw some time its a reindexe issue, but it didnt solve my problem. – Lasantha Apr 27 '18 at 6:07
2

I had the same problem. Found out some product names contained curved apostrophes instead of straight ones. It was saying successful but no products were added even after trying 4 times. I had these (’) instead of ('). Did a mass replace and then it worked.

0

if your issue still persists:

Try uploading your csv data into a Google Spreadsheet file on Google Drive and then download csv and import it. Sometimes, the regular .csv (MS-Excel or something) might have special characters or garbage characters in it and this might prevent products data from being properly imported.

0

Taking a lead from @Jean-Sebastien's answer:

I used an online tool https://pteo.paranoiaworks.mobi/diacriticsremover/ to detect and remove all non-ascii characters from my product description column and then the upload was successful.

-1

i have uploaded the csv data into a Google Spreadsheet file on Google Drive and then downloaded csv and imported successfully magento products.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.