3

Getting so many js errors. Please help me how can I fix it. I did a lot search and tried given the solution. The site is in developer mode.

require.js:166 Uncaught Error: Script error for: Magento_Ui/js/lib/knockout/bindings/mage-init
http://requirejs.org/docs/errors.html#scripterror
    at makeError (require.js:166)
    at HTMLScriptElement.onScriptError (require.js:1681)
makeError @ require.js:166
onScriptError @ require.js:1681
require.js:166 Uncaught Error: Script error for: Magento_Ui/js/lib/knockout/bindings/keyboard
http://requirejs.org/docs/errors.html#scripterror
    at makeError (require.js:166)
    at HTMLScriptElement.onScriptError (require.js:1681)
makeError @ require.js:166
onScriptError @ require.js:1681
require.js:166 Uncaught Error: Script error for: Magento_Ui/js/lib/knockout/bindings/optgroup
http://requirejs.org/docs/errors.html#scripterror
    at makeError (require.js:166)
    at HTMLScriptElement.onScriptError (require.js:1681)
makeError @ require.js:166
onScriptError @ require.js:1681
require.js:166 Uncaught Error: Script error for: Magento_Ui/js/lib/knockout/bindings/after-render
http://requirejs.org/docs/errors.html#scripterror
    at makeError (require.js:166)
    at HTMLScriptElement.onScriptError (require.js:1681)
makeError @ require.js:166
onScriptError @ require.js:1681
jquery.js:248 Uncaught Error: cannot call methods on tabs prior to initialization; attempted to call method 'option'
    at Function.error (https://garagedoors4lessstore.com/pub/static/version1501755728/frontend/Etheme/yourstore/en_US/jquery.js:248:9)
    at HTMLDivElement.<anonymous> (https://garagedoors4lessstore.com/pub/static/version1501755728/frontend/Etheme/yourstore/en_US/jquery/jquery-ui.js:488:15)
    at Function.each (https://example.com/pub/static/version1501755728/frontend/Etheme/yourstore/en_US/jquery.js:384:23)
    at jQuery.fn.init.each (https://example.com/pub/static/version1501755728/frontend/Etheme/yourstore/en_US/jquery.js:137:17)
    at jQuery.fn.init.$.fn.(anonymous function) [as tabs] (https://example.com/pub/static/version1501755728/frontend/Etheme/yourstore/en_US/jquery/jquery-ui.js:484:9)

UPDATE : GETTING sIMILAR ERROR IN ADMIN -----

admin-icons.woff2 Failed to load resource: net::ERR_CONNECTION_CLOSED
opensans-600.woff2 Failed to load resource: net::ERR_CONNECTION_CLOSED
opensans-400.woff2 Failed to load resource: net::ERR_CONNECTION_CLOSED
opensans-700.woff2 Failed to load resource: net::ERR_CONNECTION_CLOSED
magento-icon.svg Failed to load resource: net::ERR_CONNECTION_CLOSED
jquery.js Failed to load resource: net::ERR_CONNECTION_CLOSED
require.js:141 Uncaught Error: Script error for: jquery
http://requirejs.org/docs/errors.html#scripterror
    at makeError (require.js:166)
    at HTMLScriptElement.onScriptError (require.js:1681)
  • I WAS ADD SSL TODAY
  • Did u manage to fix the issue? – manini Nov 27 '17 at 6:28
2

Run both commands.

  1. First

    php bin/magento setup:upgrade

  2. Second

    php bin/magento setup:static-content:deploy

0

It looks like You include scripts without using Require.js. See Magento DevDocs. And your fonts haven't variant with *.woff2.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.