1

I want to update my Magento 1.9.1.1 over Magento connect. BUT there are only the installed extensions listed. No Magento entries order even Mage_All_Latest. So I followed some tips from this forum and tried to install Mage_All_Latest. but every time i got some errors that the files are exciting.

so how can i install Mage_All_Latest (and/or update my Magento)? i hope i don't have to build my whole site new.

enter image description here

  • can you send the error screenshot – Raghu Aug 1 '17 at 10:45
  • As you see: no magento files... so I tried to install Mage_All_Lastest with this code: connect20.magentocommerce.com/community/Mage_All_Latest Then, after Magento worked, I got the following log: Checking dependencies of packages Already installed: community/Interface_Frontend_Rwd_Default 1.9.3.4, skipping Already installed: community/Mage_Locale_en_US 1.9.3.4, skipping Already installed: community/Lib_Unserialize 1.9.3.4, skipping Already installed: community/Lib_IDNA2 1.9.3.4, skipping – Flo Aug 1 '17 at 11:50
  • CONNECT ERROR: Package 'Mage_All_Latest' is invalid '.\pkginfo\Mage_All_Latest.txt' already exists Package 'Interface_Adminhtml_Default' is invalid './app/design\adminhtml\default\default\etc\theme.xml' already exists Package 'Interface_Frontend_Default' is invalid './app/design\frontend\default\default\etc\theme.xml' already exists Package 'Interface_Install_Default' is invalid './app/design\install\default\default\etc\theme.xml' already exists ....,.and so on – Flo Aug 1 '17 at 11:51
  • so you are not getting magento packages right? – Raghu Aug 1 '17 at 12:01
4

Please follow the below steps:

  1. Copy the var/package folder from default magento1.9.1.1 and paste in your magento var/

  2. Delete pkginfo/Mage_All_Latest.txt folder

  3. After this if you still not getting upgrade options, please follow the below steps:

Go To downloader/lib/Mage/HTTP/Client/Curl.php

Find line:

$uriModified = $this->getModifiedUri($uri, $https);

Before this line write:

$https = false;

Comment this line:

$this->curlOption(CURLOPT_SSL_CIPHER_LIST, 'TLSv1');

  • 1
    please try this and let me know the progress thanks – Raghu Aug 1 '17 at 12:06
  • Yes, this will useful. – shivashankar m Aug 1 '17 at 12:30
  • hi, sorry, i wasn't on the pc... first, thanks for your tips...what do you mean with default magento? do you mean the "fresh"/"naked" magento before any theme and so on? – Flo Aug 1 '17 at 15:36
  • went great if have the options now... – Flo Aug 1 '17 at 16:41
  • but sadly it conflicts now: – Flo Aug 1 '17 at 16:41
0

Here is my magento connect (without the Mage_All_Lastest):

Magento Connect Overview

As you see: no magento files... so I tried to install Mage_All_Lastest with this code: http://connect20.magentocommerce.com/community/Mage_All_Latest

Then, after Magento worked, I got the following log:

Checking dependencies of packages Already installed: community/Interface_Frontend_Rwd_Default 1.9.3.4, skipping Already installed: community/Mage_Locale_en_US 1.9.3.4, skipping Already installed: community/Lib_Unserialize 1.9.3.4, skipping Already installed: community/Lib_IDNA2 1.9.3.4, skipping

CONNECT ERROR: Package 'Mage_All_Latest' is invalid '.\pkginfo\Mage_All_Latest.txt' already exists Package 'Interface_Adminhtml_Default' is invalid './app/design\adminhtml\default\default\etc\theme.xml' already exists Package 'Interface_Frontend_Default' is invalid './app/design\frontend\default\default\etc\theme.xml' already exists Package 'Interface_Install_Default' is invalid './app/design\install\default\default\etc\theme.xml' already exists Package 'Mage_Downloader' is invalid '.\downloader\js\prototype.js' already exists Package 'Mage_Centinel' is invalid './app/code/core\Mage\Centinel\Block\Adminhtml\Validation\Form.php' already exists Package 'Interface_Frontend_Base_Default' is invalid './app/design\frontend\base\default\etc\theme.xml' already exists Package 'Phoenix_Moneybookers' is invalid './app/code/community\Phoenix\Moneybookers\Block\Form.php' already exists Package 'Mage_Compiler' is invalid './app/code/core\Mage\Compiler\Block\Process.php' already exists Package 'Magento_Mobile' is invalid './app/code/core\Mage\XmlConnect\Block\Adminhtml\Admin\Application\Edit\Form.php' already exists Package 'Lib_Cm' is invalid './lib\Cm\Cache\Backend\Redis.php' already exists Package 'Cm_RedisSession' is invalid './app/code/community\Cm\RedisSession\Model\Session.php' already exists Package 'Mage_Core_Adminhtml' is invalid './app/code/core\Mage\Adminhtml\Block\Abstract.php' already exists Package 'Mage_Core_Modules' is invalid './app/code/core\Mage\Admin\Helper\Data.php' already exists Package 'Lib_Js_Ext' is invalid '.\js\extjs\css\README.txt' already exists Package 'Lib_LinLibertineFont' is invalid './lib\LinLibertineFont\Bugs' already exists Package 'Lib_Js_TinyMCE' is invalid '.\js\tiny_mce\classes\AddOnManager.js' already exists Package 'Lib_Varien' is invalid './lib\Varien\Autoload.php' already exists Package 'Lib_Google_Checkout' is invalid Empty package contents section Package 'Lib_Js_Calendar' is invalid '.\js\calendar\calendar-blue.css' already exists Package 'Lib_Js_Mage' is invalid '.\js\lib\FABridge.js' already exists Package 'Lib_Phpseclib' is invalid './lib\phpseclib\Crypt\AES.php' already exists Package 'Lib_Mage' is invalid './lib\Mage\Archive\Abstract.php' already exists Package 'Lib_Magento' is invalid './lib\Magento\Autoload\ClassMap.php' already exists Package 'Lib_Credis' is invalid './lib\Credis\Client.php' already exists Package 'Lib_Pelago' is invalid './lib\Pelago\Emogrifier.php' already exists Package 'Lib_ZF' is invalid './lib\Zend\Acl\Assert\Interface.php' already exists Package 'Lib_Js_Prototype' is invalid '.\js\prototype\debug.js' already exists Package 'Lib_ZF_Locale' is invalid './lib\Zend\Locale\Data\Translation.php' already exists

  • 1
    Hello and Welcome to StackExchange. This is not an answer. Please add your question details to the question itself by editing it. – Jaimin Sutariya Aug 1 '17 at 11:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.