1

I have a store-view for the Hebrew language. In which, category URL using the suffix .html.

for example- http://www.example.com/store/index.php/language/category.html

Now, I have created new store-view for another language In which category URL are not the same, default category URL(with category id) is using in newly created store-view.

for example- http://www.example.com/store/index.php/new_language/catalog/category/view/s/cream-filled-desserts/id/153/

How can I add the same category URL with .html suffix for newly created store-view.

I am using magento 1.9.0.1

| improve this question | | | | |
1

Have you reindexed, after creating the new store view?

On the server, from the Magento root, run the following:

php shell/indexer.php reindexall

Then, flush cache and test.

| improve this answer | | | | |
  • The issue has been fixed, it was the re-indexing issue. – Vinod Kumar Aug 2 '17 at 4:03
1

After to selecting store view from admin panel > catalog > Manage categories you need to uncheck the "URL Key" checkbox and save it. Then you need to reindex and clear the cache. It will work.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.