2

My project contains .modman folder, which has more than 30 modules.

So, I installed modman and tried to link each module using

modman link .modman/**** --force

its giving a message

"A module named '****' has already been checked out",

But nothing is actually linked.

Any help with this would be appreciated.

0

You get this message because you modules are already in your .modman folder and link options tries to add it again.

Instead of modman link PATH you can try

# rebuild all modman-created symlinks (no updates performed)
modman repair

Or

# deploy an existing module
modman deploy Your_Module
# deploy all modules
modman deploy-all

To skip modules from being deployed, use

# prevent a module from deploying with deploy-all
modman skip Your_Module

Some more information here: https://github.com/colinmollenhour/modman/blob/master/modman

  • 1
    Thanks a lot sv3n , it worked for me , but with --force , you are star :) – vindhya Jul 31 '17 at 11:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.