3

After customizing some files last week, both the backend and frontend of the site I’m developing for went blank. I have already searched the internet and tried out some possible solutions, but none of them works.

Somehow I can’t manage to show any error message. I already uncommented ini_set(’display_errors’, 1);, changed error_reporting(E_ALL | E_STRICT); into error_reporting(E_ALL); and I tried even more possible solutions. I also edited the memory to 128M, changed some settings in php.ini, changed local.xml.sample to local.xml. Nothing seems to work..

I seriously have no idea how I can solve this, so that’s why I’m here. I hope someone can help me. If you need more information, please ask, I don’t really know what’s necessary to answer my question.


After adding the following lines to index.php I managed to get error messages:

error_reporting(E_ALL); 
ini_set(’display_errors’, 1); 
ini_set(‘memory_limit’, ’256M’);

The error I get is:

Cannot send headers; headers already sent in /home/cheapas/public_html/index.php, line 39

Trace:

#0 /home/cheapas/public_html/lib/Zend/Controller/Response/Abstract.php(115): Zend_Controller_Response_Abstract->canSendHeaders(true) 
#1 /home/cheapas/public_html/app/code/core/Mage/Core/Model/App.php(1246): Zend_Controller_Response_Abstract->setHeader(’Content-Type’, ‘text/html; char...’) 
#2 /home/cheapas/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(80): Mage_Core_Model_App->getResponse() 
#3 /home/cheapas/public_html/app/code/core/Mage/Core/Model/Url/Rewrite.php(204): Mage_Core_Controller_Varien_Front->getResponse() 
#4 /home/cheapas/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(166): Mage_Core_Model_Url_Rewrite->rewrite() 
#5 /home/cheapas/public_html/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch() 
#6 /home/cheapas/public_html/app/Mage.php(683): Mage_Core_Model_App->run(Array) 
#7 /home/cheapas/public_html/index.php(91): Mage::run(’’, ‘store’) 
#8 {main}

Guess what, line 39 is: ini_set(‘memory_limit’, ’256M’);

When I delete this line I get a blank page again, so that doesn’t solve anything. Does anyone have an idea on solving this? Thanks!


As you may have understood, I actually can get error messages to show when I force an error by adding an unknown or uncomplete line to my index.php. Somehow there is a problem which doesn’t want to show up.

  • I don't suppose you have the code in version control so you can step back to find out which changes caused the break? – Peter O'Callaghan Apr 22 '14 at 12:52
  • Unfortunately not :( – Sandrino Apr 23 '14 at 16:17
  • Have you checked your apache error log files? Also, what happens if you call "php index.php" from command line? – simonthesorcerer Jul 28 '15 at 11:39
  • Hey simonthesorcerer. This question is over a year old. I wasn't able to resolve the problems I had at the time, so I reinstalled the theme to fix it. – Sandrino Jul 29 '15 at 10:04
4

Enable developer mode in index.php. Be sure you're not using some copy/pasta from a site like a wordpress blog, they are known to add special characters for ' and " on code snippets, judging from the code pasted, these are bad: & .

Next check var/log/system.log and var/log/exception.log. You can double check via the database by looking at core_config and finding the logging values under the path: dev/log/active. If it is set to to 0 set it to 1 to enable.

If Magento's not displaying or logging anything, then take a look at your web servers error.log file, as it will offer the most insight, if an exception is occuring above magento. You'll also want to double check your .htaccess and web server configuration for the domain.

There also may be a module or some custom code outputting (echo/print/debug/etc.) before hand, causing the error returned.

  • Thanks for your reply. Enabling developer mode didn't do anything. I checked var/log/system.log but I can't really find an error which causes this and the last error is from 18Apr. I can't find the exception.log file. I don't really understand your part about core_config. Could you explain to me how I can do that? My error.log file in cPanel is empty. – Sandrino Apr 23 '14 at 16:15
1

for headers issue in cpanel file manager please add a script as output_buffering=on; would get fixed

0

The blank screen issue can have different reasons for occurring.

It might be related to web server rewrites issue, should Apache rewrite_module be disabled (unlikely). It might be related to writing permissions on your public_html. Try running the following command via ssh console:

 chmod -R 777 /var/www/your-root/path

Also, restarting Apache can sometimes solve blank screen issues.

Side question: can someone confirm that giving 777 permissions is potential security issue?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.