0

I have moved my Magento install from one server to another, and everything seemed to go smoothly, but i am left with an issue...

Any and all scripts that are attempted to be loaded in (both frontend and backend) are prepended to be :

http://example.com/my/document/root/media/js/prototype.js ... which obviously doesn't exist... now i coudl creat a simple symlink in my folder, but i would like to find out how this has occured, since i have more then one magento instance, which i all would like to move to my new server.

I am NOT using combined scripts (yet) so i can see which are "missing" but it simply is all...

I have cleared my cache, and check read/write permissions on the media folder, and they are all correct (owned by webserver) o+w (777)...

Any thoughts are appreciated

1 Answer 1

1

Please Follow below Steps.

1. Open your core_config_data table in phpMyAdmin.

2. Find the following rows for your unsecure section, they should look like the following:

PATHVALUE web/unsecure/base_urlhttp://www.mydomain.com/ web/unsecure/base_link_url{{unsecure_base_url}} web/unsecure/base_skin_url{{unsecure_base_url}}skin/ web/unsecure/base_media_url{{unsecure_base_url}}media/ web/unsecure/base_js_url{{unsecure_base_url}}js/

3. Replace http://www.mydomain.com/ with your appropriate domain url (trailing slash necessary) and if you’ve installed in a subfolder append it with a / after it.

4. Find the following rows for your secure section, they should look like the following:

PATHVALUE web/secure/base_urlhttps://www.mydomain.com/ web/secure/base_link_url{{secure_base_url}} web/secure/base_skin_url{{secure_base_url}}skin/ web/secure/base_media_url{{secure_base_url}}media/ web/secure/base_js_url{{secure_base_url}}js/

5. Replace https://www.mydomain.com/ with your appropriate domain url (trailing slash necessary) and if you've installed in a subfolder append it with a / after it. If you haven't received your security certificate and enabled TLS/SSL yet, use http instead of https

6. Clear /var/cache, /var/session after changing base_urls and when you have access to your system reindex your URL_rewrite index. Clearing cache and sessions is necessary because your config is cached and clearing it forces a reread of the configuration data from the core_config_data table and reestablishment of sessions with the proper information.

NOTE: IF YOU HAVE SET YOUR BASE_URL correctly for web/unsecure/base_url and web/secure/base_url YOU DO NOT HAVE TO MESS AROUND WITH CHANGING THE {{UNSECURE_BASE_URL}} and {{SECURE_BASE_URL}} MACROS in the rest of the entries.

This is going to definitely work.

3
  • I have checked my base urls, and they have the ending slash, which i know can be an issue, but that didnt solve it, and if that was wrong, it would still not display my document root path And the second thing i did as well, i actually started with an empty var folder Commented Apr 21, 2014 at 16:35
  • you are something missing
    – Keyul Shah
    Commented Apr 21, 2014 at 16:36
  • chat.stackexchange.com/rooms/14044/tobias please join this room
    – Keyul Shah
    Commented Apr 21, 2014 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.